someone please help - Ford Powerstroke Diesel Forum
Powerstroke.org is the premier Diesel Truck Forum on the internet. Registered Users do not see the above ads.
Reply
 
LinkBack Thread Tools Display Modes
  #1  
Old 09-18-2010, 04:33 PM
Member
 

Join Date: Apr 2010
Posts: 46
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
someone please help

I have a 2003 f250 with the 6.0. Ever since i have owned the truck i dont have cruise countrol or trailer tow mode. Ive ran down the fuses under the dash and they check out. I was then told to search under the hood. I cant seem to find the box, To me it looks like it has been removed. There are 2 smaller fuse boxes but not the bigger one like im used to seeing. Can someone please help me in locating it? Can someone take a picture of where it should be and what it looks like? I took a few pics of the area right by the power steering fluid, has spots for bolts, but its an empty void. There are also 4 wires that have been cut. A black, a green, a yellow and i think a red one. I can email someone the pics i have and maybe they can upload them, I have no clue on how to do so......

I also have some plugs un hooked that are coming out of the brake booster. One is grey plug and the other is a black water tight plug with blue around. I sure hope someone can help me with my problems. Thank you all in advance.

Harley
Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
  #2  
Old 09-18-2010, 04:50 PM
Member
 

Join Date: Sep 2010
Location: kalamazoo,mi
Posts: 75
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
i have a 03 f-250 and i also have the same black,yellow,green and red wires that someone cut in the same location as yours im not to sure what was there but i know my truck used to have a bullydog so i always assumed that is were they had it hooked up under the hood my tow haul mode works just fine but my abs light is on and my speedo dont work ive only had the truck for like 2 weeks and havnt ever drove her yet sence its in limp mode i got mine from the company i work for
Reply With Quote Quick reply to this message
  #3  
Old 09-18-2010, 05:01 PM
Compression Ignition Addict
 

Join Date: Apr 2010
Location: Louisville, Kentucky
Posts: 312
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 1 reviews
The four wires you two are refering to are extra wires that ford put in the trucks for extra acessories for someone who might use that truck for work purposes. They all have them. As for the OP, im not sure about the other problems man. Sorry.
Reply With Quote Quick reply to this message
  #4  
Old 09-18-2010, 05:03 PM
Member
 

Join Date: Apr 2010
Posts: 46
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
Im guessing mine had some other tunner on it as well. It had an exhaust prob just dangling under the manifold. Can you take a picture of your fuse boxes under your hood? Any help would be great. I hope you get your truck up and running soon
Reply With Quote Quick reply to this message
  #5  
Old 09-18-2010, 05:05 PM
Member
 

Join Date: Apr 2010
Posts: 46
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
Thanks for the help harleystroked. Its frustraiting that i cant find this fuse box.
Reply With Quote Quick reply to this message
  #6  
Old 09-18-2010, 05:51 PM
Member
 

Join Date: Sep 2010
Location: kalamazoo,mi
Posts: 75
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
welli i guess im in the same boat you are because i have one small fuse box with two fuses and two relays under my hood just under those extra wires and no other bigger fuse box outside of the cab that i can find we have a 04 05 and a 07 at work that all have big fuse boxes under the hood? maybe the 03 just dont have one?
Reply With Quote Quick reply to this message
  #7  
Old 09-18-2010, 06:43 PM
Member
 

Join Date: Sep 2010
Location: kalamazoo,mi
Posts: 75
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
i really hope someone else with a 03 chims in and helps us either realize we both need glasses or tells us it dont exist mine is a 6.0 what is yours a 6.0 or a 7.3 they came with both in 03?
Reply With Quote Quick reply to this message
  #8  
Old 09-19-2010, 12:23 PM
Member
 

Join Date: Apr 2010
Posts: 46
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
I have a 6.0 03. I really hope someone does as well, i spent some time this am searching it over with nothing to be found. Just the 2 very small boxes
Reply With Quote Quick reply to this message
  #9  
Old 09-19-2010, 02:06 PM
Member
 

Join Date: Sep 2010
Location: kalamazoo,mi
Posts: 75
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
my speedo dont work and either does my abs heck if i dont get it figured out in the next week im just gonna sell it worth way more than i paid for it
Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Ford Powerstroke Diesel Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools
Display Modes

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On



All times are GMT -8. The time now is 05:25 PM.


Powered by vBulletin® Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Search Engine Optimization by vBSEO 3.6.1
Garage Plus, Vendor Tools vBulletin Plugins by Drive Thru Online, Inc.

vB.Sponsors