Am I paying to much????? - Ford Powerstroke Diesel Forum
 
LinkBack Thread Tools Display Modes
post #1 of 3 Old 07-15-2010, 05:50 PM Thread Starter
Powerstroke.org Rookie
 
Join Date: Jul 2010
Posts: 11
Thanks: 0
Thanked 0 Times in 0 Posts
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
Feedback Score: 0 reviews
Am I paying to much?????

So i just picked up my first 6.0L Diesel after much consideration if i wanted it or to hold out for a 7.3L. Well knowing that it had bad headgaskets and the bolts were bad i still bought it. with 60,000 Miles. The previous owner did a half *** EGR delete and it was running like Crap. So not being familiar with this motor i took it into ford and had them look at it. Told them it didnt want to start when Hot, and first thing in the morning it would take me forever to even get it to halfway sputter. Told them i had Black onyx gaskets and arp studs but wanted them to take a look. Well they looked at it and said HPOP was good but crank sensor was bad and NUM 1 and NUM 7 Injectors were not firing that was why it was running rough.

My question being is... do you guys think that paying 3800.00 is to much to have the sensor, head gaskets, and the studs done. they first quoted me at 1600.00 then the next thing i know a few days later they broke it down for me and said with all the rebuild gaskets, fluids, and 27 1/2Hrs of laber later it was almost double. Keep in mind the only Ford part i bought was the Crank Sensor which was 285.00 From Ford. Laber was around 2400.00 alone.
Critters 250 is offline  
Sponsored Links
Advertisement
 
post #2 of 3 Old 07-15-2010, 05:55 PM
shaking things up

 
jethro's Avatar
 
Join Date: Jan 2009
Location: wexford-Pa
Posts: 3,650
Thanks: 0
Thanked 1 Time in 1 Post
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
Feedback Score: 0 reviews
seems high to me did you already give them the go ahead?

389.14 HP 726.00 TQ
To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
96 f-350 7.3 with a 5 speed
3 in DP
4 in ex. to 5 in aussies
custom traction bars
TW chip 6 pos
To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.

IDM mod
SD IC
HPX
D66
casserly 2's
custom fuel with an AIRDOG 2
To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.

910's
*17 TE modded hpop
ebpv gutted
pedestal gutted
gutted ccv elbow
clutch pedal fix

To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.


To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
facebook- Graham Maxwell
jethro is offline  
post #3 of 3 Old 07-15-2010, 05:58 PM Thread Starter
Powerstroke.org Rookie
 
Join Date: Jul 2010
Posts: 11
Thanks: 0
Thanked 0 Times in 0 Posts
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
Feedback Score: 0 reviews
Not yet the only work they have done to it is the Sensor. I told them to call me before they take off or repair anything. Being a Marine In Jacksonville, NC for 4+yrs makes you very wary. Granted its been sitting in the bay this whole time(almost 2-3Weeks.) They have 2 diesel techs. and about 20+ trucks to fix
Critters 250 is offline  
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Ford Powerstroke Diesel Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in









Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome