Bad experience - Ford Powerstroke Diesel Forum
Powerstroke.org is the premier Diesel Truck Forum on the internet. Registered Users do not see the above ads.
Reply
 
LinkBack Thread Tools Display Modes
  #1  
Old 06-26-2010, 06:35 AM
Member
 

Join Date: May 2010
Posts: 45
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
Bad experience

so i pulled into the gas station to fill up my 6.0 and everything seemed fine untill i went to crank it... i put 8 oz of diesel cleen in then filled up.. but my truck wouldnt start. after about 20 mins i finally got it to start up and waddle over to a parking spot before it shut down again. when i changed oil filters i seemed to have this same problem so i turned the key over about ten times but no dice. the i took the fuel filter cap off(under the hood) and filled it with diesel and try the whole process over again.. again nothing.. i got it to fire up twice but it wouldnt idle more than a min before it bogged down and cut off.. when i checked the fuel filter again i noticed that something was wrong with the filter, the top was lose. so as i was trying to take it out the top came right off. so i tried cranking with no fuel filter... NOTHING.. i took the filter back to advanced, they gave me a new one and after rolling the key about 10 more times it crunk right up with the new filter.

i wouldnt think that having no filter or one with the top loose would cause my truck not to crank,, doesnt the filters slow down the flow??
was putting in the diesel cleen in first a mistake.. do i need to fill 3/4 or more before i add it??

also when i changed my fuel filters the first time i read that i should put sea foam in my fuel cup(im assuming thats where the front fuel filter is) but my truck acted the same then.

Sorry for the long post
Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
  #2  
Old 06-26-2010, 07:50 AM
Super Moderator


 

Join Date: Mar 2008
Location: Abingdon, Md.
Posts: 11,965
Thanks: 3
Thanked 26 Times in 15 Posts
Feedback Score: 3 reviews
The filter pushes down a spring loaded fuel shut off on the stand pipe so if you just remove the filter no fuel gets to the engine. If you openned the fuel cap and didn't have any fuel in the fuel bowl you need to replace the regulator spring. I had that problem with my 05. And I am sure everyone will tell you to only use Motorcraft or Racor filters.
Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Ford Powerstroke Diesel Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
If you do not want to register, fill this field only and the name will be used as user name for your post.
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools
Display Modes

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On



All times are GMT -8. The time now is 04:19 PM.


Powered by vBulletin® Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Search Engine Optimization by vBSEO 3.6.1
Garage Plus, Vendor Tools vBulletin Plugins by Drive Thru Online, Inc.

vB.Sponsors