6.0 info - Ford Powerstroke Diesel Forum
Powerstroke.org is the premier Diesel Truck Forum on the internet. Registered Users do not see the above ads.
Reply
 
LinkBack Thread Tools Display Modes
  #1  
Old 06-13-2010, 07:28 PM
Powerstroke.org Rookie
 

Join Date: Jun 2010
Location: Williamsport TN
Posts: 4
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
6.0 info

i drive an 03 6.0 with a superchips flashpaq on milage xs save i have no problems and the truck doesnt run hot but i smell antifreeze sometimes and it worries me a may just worry too much but i have been told by ford mechanic at local dealer i should be ok and have no problems with what i am running and i have also heard that the 03 6.0s are less roblem prone what are the suggestions as far as the diagnosis or what i should do in the future
Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
  #2  
Old 06-13-2010, 07:38 PM
Premium Member
 

Join Date: Nov 2008
Location: NWI
Posts: 909
Thanks: 0
Thanked 1 Time in 1 Post
Feedback Score: 0 reviews
It could just be the egr cooler hose. If you look down on the passanger side on top of the engine valley where the egr cooler is located, if you still have the old orange hose, it could be leaking. If its been upgraded to the blue hose, it should be ok. How many miles do you have on your truck? Is it puking out the coolant degas bottle at all? Are you having to add coolant at all? If these things check out ok, I wouldnt worry about it until it shows definate signs of coolant loss. And yes the 03's are less prone to egr cooler failure. Hope this helps.
Reply With Quote Quick reply to this message
  #3  
Old 06-13-2010, 07:42 PM
Powerstroke.org Rookie
 

Join Date: Jun 2010
Location: Williamsport TN
Posts: 4
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
as far as i know the hose has never been replaced my dad bought it new it now has 136k and its not puking anything out of the bottle he ran the programmer on performance when he had it and i put it on milage
Reply With Quote Quick reply to this message
  #4  
Old 06-13-2010, 07:44 PM
Powerstroke.org Rookie
 

Join Date: Jun 2010
Location: Williamsport TN
Posts: 4
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
and no i dont have to add any coolant
Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Ford Powerstroke Diesel Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
If you do not want to register, fill this field only and the name will be used as user name for your post.
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools
Display Modes

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On



All times are GMT -8. The time now is 04:19 PM.


Powered by vBulletin® Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Search Engine Optimization by vBSEO 3.6.1
Garage Plus, Vendor Tools vBulletin Plugins by Drive Thru Online, Inc.

vB.Sponsors