Loosing coolant - Ford Powerstroke Diesel Forum
Powerstroke.org is the premier Diesel Truck Forum on the internet. Registered Users do not see the above ads.
Reply
 
LinkBack Thread Tools Display Modes
  #1  
Old 06-09-2010, 02:16 PM
Compression Ignition Addict
 

Join Date: May 2010
Location: Orlando, FL
Posts: 157
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
Loosing coolant

I have a 06 6.0 pretty much stock (4" exhaust, coolant filter, oil bypass). I've been going through about 1 quart of coolant every 2 weeks. I have edge insight and been watching EOT and ECT, been within 10 degrees. No residue on bottle and not blowing white smoke. I've checked oil and doesn't seem to have coolant mixed with it. Any ideas EGR or head gaskets? ::
Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
  #2  
Old 06-09-2010, 02:31 PM
My 6OH Hates Me


 

Join Date: Sep 2007
Location: Nexus of the Universe
Posts: 24,702
Thanks: 8
Thanked 15 Times in 14 Posts
Feedback Score: 1 reviews
10 degrees is within spec so thats not an issue. pull your EGR valve and see if its wet. If it is your cooler is shot.
Reply With Quote Quick reply to this message
  #3  
Old 06-09-2010, 03:59 PM
Compression Ignition Addict
 

Join Date: May 2010
Location: Warren, Oregon
Posts: 1,515
Thanks: 0
Thanked 1 Time in 1 Post
Feedback Score: 0 reviews
This may help
Symptoms_of_a_Bad_EGR_Cooler
Don't know if you need this but here it is
Diesel Technician Society
Diesel Technician Society

2 stroker
Reply With Quote Quick reply to this message
  #4  
Old 06-10-2010, 03:24 PM
Compression Ignition Addict
 

Join Date: May 2010
Location: Orlando, FL
Posts: 157
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
Loosing coolant

Well I pulled my EGR valve, it wasn't wet but had a lot of carbon buildup. I cleaned it as suggested. Also it had some pretty big chunks in cavity it came out of, so I got wet vac and got out what I could. It's been 2 days since I added the 1 qt. of coolant, and it hasn't lost any so far. So if EGR doesn't look wet, which means it isn't EGR cooler, does that mean head gaskets or cracked head? Also should it be kicking out any codes?
Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Ford Powerstroke Diesel Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
If you do not want to register, fill this field only and the name will be used as user name for your post.
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools
Display Modes

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On



All times are GMT -8. The time now is 04:27 AM.


Powered by vBulletin® Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Search Engine Optimization by vBSEO 3.6.1
Garage Plus, Vendor Tools vBulletin Plugins by Drive Thru Online, Inc.

vB.Sponsors