Turbo won't spool after high EGT's - Ford Powerstroke Diesel Forum
Powerstroke.org is the premier Diesel Truck Forum on the internet. Registered Users do not see the above ads.
Reply
 
LinkBack Thread Tools Display Modes
  #1  
Old 03-14-2010, 07:26 PM
Powerstroke.org Fanatic
 

Join Date: Dec 2009
Location: NOVA
Posts: 111
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
Turbo won't spool after high EGT's

After I hit about 1200F for even a split second, I immediately let off of the accelerator until my temps drop. Once their back down, the turbo doesn't seem to want to spool back up for about 30 seconds.
Is this normal or is anyone else having this problem?
Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
  #2  
Old 03-15-2010, 06:47 PM
Powerstroke.org Fanatic
 

Join Date: Dec 2009
Location: NOVA
Posts: 111
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
No one has had this problem?
Reply With Quote Quick reply to this message
  #3  
Old 03-23-2010, 08:01 PM
Member
 

Join Date: Jan 2007
Posts: 70
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
i do but it only happens to me when i am shifting from 5th to 6th (stick). and it motors with no boost and the EGT's go way up. the only way i have found to correct mine is push in the clutch and wait till it idles and come into the throttle slow. or shift back into 5th and try again.
Reply With Quote Quick reply to this message
  #4  
Old 04-11-2010, 06:07 PM
Powerstroke.org Fanatic
 

Join Date: Dec 2009
Location: NOVA
Posts: 111
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
This is still happening to me and seems to be getting worse, wondering if my turbo is about to go.
After I peg 12k for a second, turbo is dead in the water
Reply With Quote Quick reply to this message
  #5  
Old 04-11-2010, 06:29 PM
Member
 

Join Date: Mar 2010
Location: va beach, va
Posts: 46
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
Quote:
Originally Posted by Nova_gts View Post
This is still happening to me and seems to be getting worse, wondering if my turbo is about to go.
After I peg 12k for a second, turbo is dead in the water
bump...subscribed
Reply With Quote Quick reply to this message
  #6  
Old 04-12-2010, 05:12 PM
Powerstroke.org Fanatic
 

Join Date: Dec 2009
Location: NOVA
Posts: 111
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
You having the same problem Chris?
I can't believe no one else has had/fixed it? It's the worst feeling in the world when u take off and then your truck basically stops in the middle of the road (especially if going up hill).
Reply With Quote Quick reply to this message
  #7  
Old 04-26-2010, 06:23 PM
Powerstroke.org Fanatic
 

Join Date: Dec 2009
Location: NOVA
Posts: 111
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
One more bump and
Reply With Quote Quick reply to this message
  #8  
Old 04-27-2010, 06:07 AM
Compression Ignition Addict
 

Join Date: Nov 2009
Location: bozeman
Posts: 215
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
what kind of programer are you using?
Reply With Quote Quick reply to this message
  #9  
Old 04-27-2010, 06:04 PM
Powerstroke.org Fanatic
 

Join Date: Dec 2009
Location: NOVA
Posts: 111
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
SCT with IDP Xstreet tune
Reply With Quote Quick reply to this message
  #10  
Old 04-27-2010, 08:20 PM
Compression Ignition Addict
 

Join Date: Nov 2009
Location: bozeman
Posts: 215
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
try detuning it and see what it does
Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Ford Powerstroke Diesel Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
If you do not want to register, fill this field only and the name will be used as user name for your post.
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools
Display Modes

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On



All times are GMT -8. The time now is 05:50 AM.


Powered by vBulletin® Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Search Engine Optimization by vBSEO 3.6.1
Garage Plus, Vendor Tools vBulletin Plugins by Drive Thru Online, Inc.

vB.Sponsors