middle top instrument problems - Ford Powerstroke Diesel Forum
User Tag List

 
LinkBack Thread Tools Display Modes
post #1 of 5 Old 12-30-2009, 10:43 PM Thread Starter
Compression Ignition Addict
 
Join Date: Feb 2009
Location: Antlers, Oklahoma 74523
Posts: 211
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
Send a message via Yahoo to cxrxaxz
middle top instrument problems

My middle instrument cluster quit working on me. Its the one that tell you your mpg and the temp outside etc. I dont know what happened i just noticed it was off one day and i gave it a strong tap and it came back on. Then noticed it off again today and tapped it again and it did not come back on. Do you guys think this could just be the bulb going out? or something more? how hard is it to replace the bulb in thoes things so i can go ahead and rule that out? Also would this have anything to do with unplugin my erg? cause when i first noticed it was right after i decided to unplug my egr valve.
cxrxaxz is offline  
post #2 of 5 Old 12-30-2009, 10:45 PM Thread Starter
Compression Ignition Addict
 
Join Date: Feb 2009
Location: Antlers, Oklahoma 74523
Posts: 211
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
Send a message via Yahoo to cxrxaxz
one other thing. anyone know what size bulb? or where to get them? can you put a different color in other then green? i think blue would look nice.
cxrxaxz is offline  
post #3 of 5 Old 12-31-2009, 09:24 AM Thread Starter
Compression Ignition Addict
 
Join Date: Feb 2009
Location: Antlers, Oklahoma 74523
Posts: 211
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
Send a message via Yahoo to cxrxaxz
bump be bump bump bumpppppppp
cxrxaxz is offline  
post #4 of 5 Old 12-31-2009, 09:32 AM
Rob
Super Moderator



 
Rob's Avatar
 
Join Date: Aug 2006
Location: Layton, Utah
Posts: 13,244
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 2 Post(s)
Thanks: 3
Thanked 7 Times in 4 Posts
Feedback Score: 0 reviews
Send a message via AIM to Rob Send a message via MSN to Rob Send a message via Skype™ to Rob
Have you pulled it down to check the wiring??

Rob, The Investigator!
Audentes Fortuna Juvat
(Fortune Favors The Bold)
Rwalker@Powerstroke.Org
The Org. Staff reserves the right to
move, modify, delete or merge threads/posts
at our discretion, without explanation
at any time.

Rob is offline  
post #5 of 5 Old 12-31-2009, 09:40 AM
PROUD AMERICAN!!!




 
Rattlesnake18's Avatar
 
Join Date: Nov 2009
Location: Wheat Ridge, Colorado
Posts: 19,208
Mentioned: 33 Post(s)
Tagged: 1 Thread(s)
Quoted: 321 Post(s)
Thanks: 190
Thanked 478 Times in 398 Posts
Feedback Score: 6 reviews
Quote:
Originally Posted by cxrxaxz View Post
My middle instrument cluster quit working on me. Its the one that tell you your mpg and the temp outside etc. I dont know what happened i just noticed it was off one day and i gave it a strong tap and it came back on. Then noticed it off again today and tapped it again and it did not come back on. Do you guys think this could just be the bulb going out? or something more? how hard is it to replace the bulb in thoes things so i can go ahead and rule that out? Also would this have anything to do with unplugin my erg? cause when i first noticed it was right after i decided to unplug my egr valve.
Not sure if it will help, but I had found this thread a lil while back. Going to check mine out when I install cab lights. http://www.powerstroke.org/forum/99-...asy-works.html Hope this helps ya!


2004 F250 CC Lariat 4x4

Pro Comp leveling kit, 05-07 HD headlights w/ 6k HIDs, Auto Meter gauges, ScanGaugeII, Sinister coolant filter, Blue spring, 6.4 banjo bolts, BPD FICM, BPD billet water pump, BPD VK688 oil cooler kit, S&B CAI, MTW stage 2, Straight piped w/ 6" single mitre stack, SCT w/ Hybrid Panty Dropper from Chris @ TSD, Fumoto block drain valves, ELC, High idle mod

Quote:
Originally Posted by djmaguire View Post
I'm guessing that you didn't lose nearly as much as it appeared. Spills are like that. The last beer that I spilled was like a million ounces.
Rattlesnake18 is offline  
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Ford Powerstroke Diesel Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in









Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome