oil leak question? - Ford Powerstroke Diesel Forum
Powerstroke.org is the premier Diesel Truck Forum on the internet. Registered Users do not see the above ads.
Reply
 
LinkBack Thread Tools Display Modes
  #1  
Old 03-26-2007, 04:19 PM
Compression Ignition Addict
 

Join Date: Mar 2006
Location: St Augustine, FL
Posts: 366
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
oil leak question?

Ok, have recently started towing a 6x12 enclosed trailor and had some things done in preperation, 1 trans service: drop pan, new trans filter and trans oil. 2 fix rear pinion seal leak. The shop that did this work told me I had an oil leak at the cylinder head on the passenger side. Now, I've heard some of the techs on here say that "if it's not hitting the ground than don't worry."
Well, no oil has stained my driveway but this does concern me. I have been told that I'm almost a quart low at my oil changes. 3000 to 4000 miles. I just assumed I was burning some oil. Should I be concerned? I have 58,000.00 miles on it now and it runs fine.

Scott
Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
  #2  
Old 03-26-2007, 04:33 PM
duct tape & zip ties

 

Join Date: Jul 2006
Location: Willis, MI
Posts: 10,761
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
Send a message via Yahoo to bigcountrysg
You have 58,000 miles on it. It is a 2006, Take it to the dealer it is under warranty. You may need new head bolts as yours may have been stretched. They also will have to replace the head gaskets as well.
Reply With Quote Quick reply to this message
  #3  
Old 03-26-2007, 04:36 PM
Compression Ignition Addict
 

Join Date: Jan 2007
Location: mooresville, nc
Posts: 1,436
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
when you pull your trailer do you baby it or do you get on it maybe going up hills or anything like that........ and you most likely dont need to worry the much its prolly just a loose clamp on a hose possibly the result of expanding and contracting from more boost then its regularly sees this could come from pulling a trailer up hill and getting your boost up there....... and then theres always your typical bad o-ring or seal which isnt much..... im no mechanic though just talkin through past experiences...... you shouldnt worry though
Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Ford Powerstroke Diesel Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
If you do not want to register, fill this field only and the name will be used as user name for your post.
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools
Display Modes

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On



All times are GMT -8. The time now is 08:59 AM.


Powered by vBulletin® Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Search Engine Optimization by vBSEO 3.6.1
Garage Plus, Vendor Tools vBulletin Plugins by Drive Thru Online, Inc.

vB.Sponsors