Fuel additive? - Ford Powerstroke Diesel Forum
Powerstroke.org is the premier Diesel Truck Forum on the internet. Registered Users do not see the above ads.
Reply
 
LinkBack Thread Tools Display Modes
  #1  
Old 03-18-2007, 06:11 AM
Powerstroke.org Rookie
 

Join Date: Mar 2007
Posts: 18
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
Fuel additive?

I'm reading on here all the posts about soot and gunk on the egr and turbo vains and such,just wondering if something like lucas or similar would help with this problem or is this a design flaw?
Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
  #2  
Old 03-18-2007, 06:23 AM
Compression Ignition Addict
 

Join Date: Jun 2006
Posts: 559
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
Send a message via AIM to trhland
Quote:
Originally Posted by 04PSD View Post
I'm reading on here all the posts about soot and gunk on the egr and turbo vains and such,just wondering if something like lucas or similar would help with this problem or is this a design flaw?
i use diesel kleen .the white bottle. every now and then. no probs so far
Reply With Quote Quick reply to this message
  #3  
Old 03-18-2007, 06:26 AM
Banned
 

Join Date: Sep 2006
Location: Jarrettsville, MD
Posts: 0
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
I use diesel kleen, but I'm going to switch to the Motorcraft Cetane Booster. It's cheaper and everybody seems to think it's more effective. I haven't been impressed with the Diesel Kleen in the white bottle. Last fall I used the grey bottle and it seemed better.
Reply With Quote Quick reply to this message
  #4  
Old 03-18-2007, 06:45 AM
Powerstroke.org Rookie
 

Join Date: Mar 2007
Posts: 18
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
I started using lucas a couple of months ago to make up for the low sulfur fuel. But i'v had problems with this for some time [junk on egr] about a year. Had my truck back to ford with 2000 miles on it. It was pushing water/anti. 23000 miles later they put new heads on it,but a week before it went in it started losing power,poping,black smoke ect... now I know its the egr. Ford tryed to tell me it was making to much boost and blowing off the excess.So I finally went to ford friday to take a tec for a ride and thats when he told me its the egr. Got on here and found the solution, unplug the egr! who would a thunk it Maybe i'll try something other than lucas. It can't be helping any.
Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Ford Powerstroke Diesel Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
If you do not want to register, fill this field only and the name will be used as user name for your post.
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools
Display Modes

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On



All times are GMT -8. The time now is 02:40 AM.


Powered by vBulletin® Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Search Engine Optimization by vBSEO 3.6.1
Garage Plus, Vendor Tools vBulletin Plugins by Drive Thru Online, Inc.

vB.Sponsors