Service Life of 6.0 electric fuel pumps? - Ford Powerstroke Diesel Forum
User Tag List

 
LinkBack Thread Tools Display Modes
post #1 of 3 Old 11-02-2009, 09:14 PM Thread Starter
Powerstroke.org Fanatic
 
Join Date: Oct 2009
Location: Kamloops, BC Canada
Posts: 137
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
Service Life of 6.0 electric fuel pumps?

Hey all you 6 litre G&G's

Wanting to know if you get good service life from your Electric fuel pumps and if you have experienced any short comings of this set up.

Reason I am asking is looking to use the 6.0 integrated fuel pump/filter/heater/water seperator on my '97, as I want to strip the mechanical keerap off my truck and convert to electric. Like the notion of an all in one set up as the 6.0 has and will probably put in a pre pump filter and post pump filter too....just for fun.

thanks for your insights,

jrc

'97 Red F250 CC XLT ZF5 3:55s, Dana 60, SD springs all round, 'jectors, IC, 6.0 fan, TW files, VisionX lights and other stuff.

'96 White/Silver F250 SCSB 4X2 (all stock for now)... 4:10's E4OD.

Truck Pix & write ups
jcart is offline  
post #2 of 3 Old 11-04-2009, 07:48 AM Thread Starter
Powerstroke.org Fanatic
 
Join Date: Oct 2009
Location: Kamloops, BC Canada
Posts: 137
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
So I take it no one has had a fuel pump failure with their trucks......Sounds good to me...

jrc

'97 Red F250 CC XLT ZF5 3:55s, Dana 60, SD springs all round, 'jectors, IC, 6.0 fan, TW files, VisionX lights and other stuff.

'96 White/Silver F250 SCSB 4X2 (all stock for now)... 4:10's E4OD.

Truck Pix & write ups
jcart is offline  
post #3 of 3 Old 11-04-2009, 09:44 AM
Powerstroke.org Fanatic
 
05KingRanchDually's Avatar
 
Join Date: Sep 2008
Posts: 128
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
Mine died at 82267 miles. I think an improperly seated filter had a little to do with it.
05KingRanchDually is offline  
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Ford Powerstroke Diesel Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in









Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome