surging and inconsistant idle - Ford Powerstroke Diesel Forum
Powerstroke.org is the premier Diesel Truck Forum on the internet. Registered Users do not see the above ads.
Reply
 
LinkBack Thread Tools Display Modes
  #1  
Old 09-25-2009, 01:48 AM
Powerstroke.org Fanatic
 

Join Date: May 2009
Posts: 115
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
surging and inconsistant idle

Hi

I've got an inconsistant idle (jumps from 600 up to 1000-1050 and then quickly back down) as well as surging while driving.

Possible diagnosis?

Bad turbo?
Bad oil controlling injectors?
Bad injectors?
Bad cam positioning sensor?
Bad crank positioning sensor?
Poor air intake (kinda "feels" like it's starved for air when driving between surges)?
Poor exhaust?
Bumpy ride and driver can't keep his foot still?

Any and all ideas wanted...

Thanks!
Patrick
Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
  #2  
Old 09-25-2009, 03:16 AM
Compression Ignition Addict
 

Join Date: Apr 2007
Posts: 2,542
Thanks: 8
Thanked 11 Times in 8 Posts
Feedback Score: 0 reviews
What year model truck?
What mods?
What repair history?
Any codes (can get codes w/ no CEL)?
What are your routine maintenance practices?
Reply With Quote Quick reply to this message
  #3  
Old 09-25-2009, 09:11 AM
Powerstroke.org Fanatic
 

Join Date: May 2009
Posts: 115
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
I suppose that info would be helpful huh?

2004 F350, 6.0, auto, crew cab, 4x4, 90k miles

2" spring lift, Superchips economy program

No codes with Superchips diagnostic function

Recently repairs;
freed up siezed brakes in the rear...replaced rotors and pads
freed up siezed brakes in front...replaced pads...rotors were still good
replaced cam sensor
replaced exhaust pressure sensor
replaced air filter minder.

Purchased 2 months ago...have put on about 1000 miles. Came with a fresh Amsoil oil change. Run a fuel additive put I forget the brand off hand...though it's been mentioned on here a number of times...White bottle with red top...wish I could remember off hand...will have to go check...

Thanks for any help...
Reply With Quote Quick reply to this message
  #4  
Old 09-25-2009, 09:58 AM
Compression Ignition Addict
 

Join Date: Feb 2009
Posts: 551
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
may want to pull the plug on the ICP sensor while its running and see if it smoothes out, if so, replace the sensor, your truck is a 2004 so it is below and behind the turbocharger which is a bearcat to get at. good luck.
Reply With Quote Quick reply to this message
  #5  
Old 09-25-2009, 10:00 AM
The Fat Mod
 
Join Date: Aug 2006
Location: Hickory, NC
Posts: 12,509
Thanks: 0
Thanked 1 Time in 1 Post
Feedback Score: 0 reviews
Mine does it too. Not sure what it is. I have heard many different things. I hope to get mine on AE this weekend.
Reply With Quote Quick reply to this message
  #6  
Old 09-25-2009, 10:45 AM
Compression Ignition Addict
 

Join Date: Apr 2007
Posts: 2,542
Thanks: 8
Thanked 11 Times in 8 Posts
Feedback Score: 0 reviews
Quote:
Originally Posted by hazard View Post
may want to pull the plug on the ICP sensor while its running and see if it smoothes out, if so, replace the sensor, your truck is a 2004 so it is below and behind the turbocharger which is a bearcat to get at. good luck.
I agree! However - the late 2004's have the ICP on the passengher valve cover (maybe you will get lucky).
Reply With Quote Quick reply to this message
  #7  
Old 09-26-2009, 07:05 AM
Powerstroke.org Fanatic
 

Join Date: May 2009
Posts: 115
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
I haven't yet got a chance to check the ICP...my problem is intermittent so I don't think it would help much if I unplug it when I'm not having problems.

But...Some more info...
This problem, while it does occassionally happen when the motor is cold...it happens much more frequently when it's warm.

A mechanic friend was thinking it sounded more like an EGR issue...but wouldn't EGR issues throw a code? I didn't get one with my superchips...would another code reader maybe get one?

Thanks,
Patrick
Reply With Quote Quick reply to this message
  #8  
Old 09-26-2009, 07:41 AM
Compression Ignition Addict
 

Join Date: Apr 2007
Posts: 2,542
Thanks: 8
Thanked 11 Times in 8 Posts
Feedback Score: 0 reviews
With the synptoms you describe, the most likely candidates are:

ICP
IPR
High Pressure Oil system leak
Reply With Quote Quick reply to this message
  #9  
Old 09-26-2009, 07:53 AM
Compression Ignition Addict
 

Join Date: Jun 2009
Location: Molalla, Oregon
Posts: 957
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
I need to stop fixing 6.0 liters and just start selling parts, I'd make a killing LOL!!!!!!!
Reply With Quote Quick reply to this message
  #10  
Old 09-26-2009, 06:05 PM
Powerstroke.org Fanatic
 

Join Date: May 2009
Posts: 115
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
Quote:
Originally Posted by bismic View Post
With the synptoms you describe, the most likely candidates are:

ICP
IPR
High Pressure Oil system leak
ICP - Injection Control Pressure?

IPR - Injection ...?

High pressure oil system leak...just thinking out loud...injectors controlled by oil...so if there's an oil leak in that system...the injectors aren't going to work properly...

Any tips on how to diagnose those if they aren't throwing a code?

ICP - pull when running rough...if it smooths out, replace it.

IPR - ?

HP Oil Leak...Look for oil...where abouts?

Thanks!
Patrick
Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Ford Powerstroke Diesel Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
If you do not want to register, fill this field only and the name will be used as user name for your post.
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools
Display Modes

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On



All times are GMT -8. The time now is 02:58 AM.


Powered by vBulletin® Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Search Engine Optimization by vBSEO 3.6.1
Garage Plus, Vendor Tools vBulletin Plugins by Drive Thru Online, Inc.

vB.Sponsors