Help.....No MAF sensor on my truck - Ford Powerstroke Diesel Forum
Powerstroke.org is the premier Diesel Truck Forum on the internet. Registered Users do not see the above ads.
Reply
 
LinkBack Thread Tools Display Modes
  #1  
Old 09-24-2009, 11:44 AM
Compression Ignition Addict
 

Join Date: Jun 2007
Location: Grand Ledge Michigan
Posts: 654
Thanks: 0
Thanked 1 Time in 1 Post
Feedback Score: 0 reviews
Help.....No MAF sensor on my truck

Here in Michigan I'm having a hard time finding 6.0 experts and took my truck in yesterday to an independent shop to diagnos a smokeing at start up and rough running until warm issue. The tech just called and asked me why my MAF sensor was removed and had a dummy plug plugged in. I have no idea, do any of you??
He said once warm it ran like a raped ape......He's not familiar with SCT.
Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
  #2  
Old 09-24-2009, 12:22 PM
Compression Ignition Addict
 

Join Date: Jun 2007
Location: Grand Ledge Michigan
Posts: 654
Thanks: 0
Thanked 1 Time in 1 Post
Feedback Score: 0 reviews
Nevermind. The tech just called and said some 6.0's didn't have the sensor......He still can't figure out the issue. He said all the glow plugs checked out which was what he originally thought the problem was.

It's running really rich until warm.......
Reply With Quote Quick reply to this message
  #3  
Old 09-24-2009, 12:24 PM
Compression Ignition Addict
 

Join Date: Sep 2007
Location: Toms River, NJ
Posts: 3,720
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
Send a message via AIM to 03f250stroke
and that thing isnt surging like crazy?

i had mine unplugged and it was a nightmare to drive. unless whoever tuned your truck turned the maf sensor off
Reply With Quote Quick reply to this message
  #4  
Old 09-24-2009, 12:27 PM
Compression Ignition Addict
 

Join Date: Jun 2007
Location: Grand Ledge Michigan
Posts: 654
Thanks: 0
Thanked 1 Time in 1 Post
Feedback Score: 0 reviews
Quote:
Originally Posted by 03f250stroke View Post
and that thing isnt surging like crazy?

i had mine unplugged and it was a nightmare to drive. unless whoever tuned your truck turned the maf sensor off
When cold it runs rough and then bucks when it trys to lock the torque converter. Once warm (about 5-10 minutes) it runs great.
Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Ford Powerstroke Diesel Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
If you do not want to register, fill this field only and the name will be used as user name for your post.
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools
Display Modes

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On



All times are GMT -8. The time now is 12:42 AM.


Powered by vBulletin® Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Search Engine Optimization by vBSEO 3.6.1
Garage Plus, Vendor Tools vBulletin Plugins by Drive Thru Online, Inc.

vB.Sponsors