Power loss and miss when cold. Need some help - Ford Powerstroke Diesel Forum
Powerstroke.org is the premier Diesel Truck Forum on the internet. Registered Users do not see the above ads.
Reply
 
LinkBack Thread Tools Display Modes
  #1  
Old 09-02-2009, 06:47 PM
Compression Ignition Addict
 

Join Date: Feb 2009
Location: Fairfield, MT
Posts: 589
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
Power loss and miss when cold. Need some help

I let my truck warm up every morning at least 5 ten minutes before I take off. So its pretty warmed up. When I take off and get to about 2000 to 2500 rpms it jus cuts out bad and acts like an injector.Then if I floor it and drive it hard it will seem to clean out and run fine. Soon as its good and warmed up runs like a champ. Fuel filters always changed. I had it at ford about 3 months ago and had #7 injector replaced and they said the rest were fine. Then ran like crap took it back and the egr valve went out. So I replaced that.Also has a new fuel pump to cause that also went out. Now it still does it. If anybody has any ideas of what to do or what it is i would appreciate it. I am thinking of going in and having the computer reflashed and have injectors checked again though.
Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
  #2  
Old 09-02-2009, 08:32 PM
Compression Ignition Addict
 

Join Date: Aug 2008
Posts: 420
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
Send a message via AIM to BLKF250
What kinds of S & S are you having? any like this

Rought cold starts
Rough until warming temp
lack of power until warming temp
miss firing

If you have any of those then its an injector. All it takes is just one to fail and you will get what your saying so answer those questions above and we can go from there
Reply With Quote Quick reply to this message
  #3  
Old 09-02-2009, 08:35 PM
Compression Ignition Addict
 

Join Date: Jun 2007
Location: west covina, CA
Posts: 1,930
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
mine acts the same way .....
Reply With Quote Quick reply to this message
  #4  
Old 09-02-2009, 08:40 PM
Compression Ignition Addict
 

Join Date: Dec 2007
Location: Flint, MI
Posts: 4,057
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
Where's dave when ya need him.
Reply With Quote Quick reply to this message
  #5  
Old 09-02-2009, 08:41 PM
Rice Hunter
 

Join Date: Aug 2007
Location: Norfolk,VA...Near the beach
Posts: 4,036
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
Try some good fuel additive! Diesel Kleen etc.
Wish Ya Luck!!
Reply With Quote Quick reply to this message
  #6  
Old 09-02-2009, 08:43 PM
Compression Ignition Addict
 

Join Date: Jun 2007
Location: west covina, CA
Posts: 1,930
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
so they could be just plugged or some of them
Reply With Quote Quick reply to this message
  #7  
Old 09-03-2009, 05:05 AM
Compression Ignition Addict
 

Join Date: Feb 2009
Location: Fairfield, MT
Posts: 589
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
I run the additive all the time. Kinda makes a diff but not really. It starts fine, idles fine, and takes off fine but then it just takes a crap in the midrange. Im gettn an sct so guess il just go down to ford and get it checked and puter reflashed
Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Ford Powerstroke Diesel Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools
Display Modes

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On



All times are GMT -8. The time now is 12:16 PM.


Powered by vBulletin® Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Search Engine Optimization by vBSEO 3.6.1
Garage Plus, Vendor Tools vBulletin Plugins by Drive Thru Online, Inc.

vB.Sponsors