turbo help - Ford Powerstroke Diesel Forum
User Tag List

 
LinkBack Thread Tools Display Modes
post #1 of 5 Old 07-16-2009, 12:54 PM Thread Starter
Powerstroke.org Rookie
 
Join Date: Jul 2009
Posts: 8
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
turbo help

Ok the run down here is we have a 2003 6.0. The oil cooler melted down and was leaking oil into the coolant. So we ordered the liberator performance remote oil cooler kit and the egr delete kit. We got everything installed and hooked back up and then we had some turbo problems. We replaced the turbo with a brand new reman'd unit and the truck ran fine for a few weeks. Now we are back to no boost and throwing turbocharger performance codes again. Any ideas here? Truck starts fine and ran fine before the tear down.
KyleOH is offline  
post #2 of 5 Old 07-16-2009, 12:59 PM
Lt. Negativity
 
RescueF250's Avatar
 
Join Date: Jun 2007
Location: Stafford
Posts: 1,738
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Thanks: 0
Thanked 1 Time in 1 Post
Feedback Score: 0 reviews
First question do you have a SCT tuner ?? IF not theres your problems

1st off- you got a EGR delete kit not without a tuner eliminating that in the tune your probably gonna throw codes on a stock truck I think not 100 percent sure.

2nd what turbo did you installed ? 03 or another year ? is the VGT plugged up correctly ? What codes are being thrown ? Where did you get the turbo sounds like maybe a bad turbo or VGT selniod. If I think of more I'll post up. Also post up the codes you got.

Matt at Gearhead,Doug at GoGo,Dave at Diesel Innovations,Ryan at Full Force Diesel,Eric at Innovative. Adam at First Coast

Built 2003 with 04.5-07 parts,Hey its a hybrid . Totaled

New Era Rescue 08 F250 CC/SB No limit stuff, H&S stuff, Fl pro stuff.
RescueF250 is offline  
post #3 of 5 Old 07-16-2009, 01:06 PM Thread Starter
Powerstroke.org Rookie
 
Join Date: Jul 2009
Posts: 8
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
Thanks for the reply. The truck has a edge juice w/Att on it. We were told that nothing was needed but just install the kit. The EGR is actually still plugged in it doesn't throw codes on the EGR side. I will have to post up the exact codes when I get to the house tonight in about an hour. Turbocharger performance is all I can really remember on it.

It was an 03 turbo from MI Turbo.

Last edited by KyleOH; 07-16-2009 at 01:09 PM.
KyleOH is offline  
post #4 of 5 Old 07-16-2009, 01:15 PM
Lt. Negativity
 
RescueF250's Avatar
 
Join Date: Jun 2007
Location: Stafford
Posts: 1,738
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Thanks: 0
Thanked 1 Time in 1 Post
Feedback Score: 0 reviews
Edge is one part of your problem to begin with. Toss it and get an SCT. As for the EGR aspect I'm not 100 percent sure hopefully someone else chimes in on that. post the codes it help us try and figure it out for you better.

Matt at Gearhead,Doug at GoGo,Dave at Diesel Innovations,Ryan at Full Force Diesel,Eric at Innovative. Adam at First Coast

Built 2003 with 04.5-07 parts,Hey its a hybrid . Totaled

New Era Rescue 08 F250 CC/SB No limit stuff, H&S stuff, Fl pro stuff.
RescueF250 is offline  
post #5 of 5 Old 07-20-2009, 07:22 AM Thread Starter
Powerstroke.org Rookie
 
Join Date: Jul 2009
Posts: 8
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
Ok well the truck ran fine for a few days after we unplugged the egr. Made good boost 23lb and had no problems. Then sitting in the driveway it started to throw codes. I didn't reply and codes before because it started running fine and no codes.

Well now AGAIN no boost and getting codes P2263 , and P0403 . I know the second one is EGR related but we never got this one before even with the EGR unplugged. Any ideas besides the stupid edge box, (truck ran with the edge for over 30,000 miles)
KyleOH is offline  
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Ford Powerstroke Diesel Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in









Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome