might have a problem not sure... - Ford Powerstroke Diesel Forum
Powerstroke.org is the premier Diesel Truck Forum on the internet. Registered Users do not see the above ads.
Reply
 
LinkBack Thread Tools Display Modes
  #1  
Old 07-15-2009, 06:20 PM
Compression Ignition Addict
 

Join Date: Mar 2009
Location: Butte, Montana
Posts: 334
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
might have a problem not sure...

today i was on the high way and needed to pass a car before some road construction and got on it pretty hard but i didnt let my egts get past 1150. Then about a half a mile later when i got off the high way my truck started blowing whiteish gray smoke. after about another mile the smoke started to get darker and finally it turned black again. i've heard this is a sigh of a blown egr. the only mods ive done to my truck so far are an sct and 4in tb exhaust. any help is great thanks!
Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
  #2  
Old 07-16-2009, 03:00 PM
Lt. Negativity
 

Join Date: Jun 2007
Location: Stafford
Posts: 1,734
Thanks: 0
Thanked 1 Time in 1 Post
Feedback Score: 0 reviews
Ya it could be the egr/cooler, or head gaskets. I'd start with a EGR delete kit. hope that solves your problem.
Reply With Quote Quick reply to this message
  #3  
Old 07-16-2009, 03:10 PM
Compression Ignition Addict
 

Join Date: Jul 2007
Posts: 5,424
Thanks: 1
Thanked 8 Times in 8 Posts
Feedback Score: 0 reviews
did the CEL come on at all? scan it and see if it set any codes. proper diagnosis is needed, dont throw parts at it.
Reply With Quote Quick reply to this message
  #4  
Old 07-16-2009, 03:46 PM
Compression Ignition Addict
 

Join Date: Dec 2007
Location: Ft. Knox/Flaherty Ky
Posts: 818
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
Quote:
Originally Posted by ianstew View Post
did the CEL come on at all? scan it and see if it set any codes. proper diagnosis is needed, dont throw parts at it.
agreed. You can waste a ton of time and money without finding the problem doing this.
Reply With Quote Quick reply to this message
  #5  
Old 07-17-2009, 09:44 AM
Compression Ignition Addict
 

Join Date: Mar 2009
Location: Butte, Montana
Posts: 334
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
no it didnt show a CEL
Reply With Quote Quick reply to this message
  #6  
Old 07-17-2009, 09:56 AM
Powerstroke.org Fanatic
 

Join Date: Jun 2008
Location: fuquay-Varina
Posts: 101
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
Quote:
Originally Posted by ianstew View Post
did the CEL come on at all? scan it and see if it set any codes. proper diagnosis is needed, dont throw parts at it.
Will the CEL come on if it's a egr problem?
Reply With Quote Quick reply to this message
  #7  
Old 07-17-2009, 06:18 PM
Compression Ignition Addict
 

Join Date: Dec 2007
Location: Ft. Knox/Flaherty Ky
Posts: 818
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
Quote:
Originally Posted by ndennis93 View Post
Will the CEL come on if it's a egr problem?
yes, it should
Reply With Quote Quick reply to this message
  #8  
Old 07-17-2009, 07:04 PM
Compression Ignition Addict
 

Join Date: Sep 2007
Location: Toms River, NJ
Posts: 3,720
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
Send a message via AIM to 03f250stroke
depends on the year of the truck..my 03 has never thrown a CEL and i have had many codes stored when i scanned the truck.

i would pull the valve out and clean it. i bet its dirty.

what year truck?
Reply With Quote Quick reply to this message
  #9  
Old 07-17-2009, 08:00 PM
Compression Ignition Addict
 

Join Date: Mar 2009
Location: Butte, Montana
Posts: 334
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
its an 05 with 48XXX on the ticker
Reply With Quote Quick reply to this message
  #10  
Old 07-17-2009, 08:03 PM
Compression Ignition Addict
 

Join Date: Sep 2007
Location: Toms River, NJ
Posts: 3,720
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
Send a message via AIM to 03f250stroke
it would most likely throw a code.

i would clean it first..cheapest too
Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Ford Powerstroke Diesel Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
If you do not want to register, fill this field only and the name will be used as user name for your post.
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools
Display Modes

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On



All times are GMT -8. The time now is 06:18 PM.


Powered by vBulletin® Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Search Engine Optimization by vBSEO 3.6.1
Garage Plus, Vendor Tools vBulletin Plugins by Drive Thru Online, Inc.

vB.Sponsors