Altenator not charging/ ignition switch not working - Ford Powerstroke Diesel Forum
Ford Gassers A Place for Diesel nuts to discuss Ford Gasoline powered vehicles!!!

User Tag List

 
LinkBack Thread Tools Display Modes
post #1 of 2 Old 06-14-2009, 03:54 PM Thread Starter
Compression Ignition Addict
 
Jason812's Avatar
 
Join Date: Jun 2008
Location: McGregor, TX
Posts: 534
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Thanks: 0
Thanked 1 Time in 1 Post
Feedback Score: 0 reviews
Altenator not charging/ ignition switch not working

I have an 82 J10 that I had a dead battery on and I thought the altenator was bad. I replaced the battery today and had the altenator tested and it's fine. I also replaced the starter selonoid (Old ford style on the fender well). Here's whats going on.

Turn the key on, nothing comes on that should with the key. Truck acts like the battery is not connected. Leave the key on, jump the selonoid with a screw driver, truck cranks right up and all accessories work. Voltage to the battery & battery side of the selonoid is 12.36 (same as not running) but the voltage coming out of the back of the altenator is 14.8 & is the same as the ignition side of the starter selonoid. While the truck is running, I turn the key off and it dies just like it should.

Is this a bad ignition (GM style) switch or is there an ignition relay that may be bad? I'll have to pull the steering wheel to replace the ignition switch if it's bad & I really don't want to.

2002 4X4 XLT EX - Air Dog
Jason812 is offline  
Sponsored Links
Advertisement
 
post #2 of 2 Old 06-21-2009, 08:50 PM Thread Starter
Compression Ignition Addict
 
Jason812's Avatar
 
Join Date: Jun 2008
Location: McGregor, TX
Posts: 534
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Thanks: 0
Thanked 1 Time in 1 Post
Feedback Score: 0 reviews
Got it fixed. The hot wire coming from the battery side of the selonoid was corroded into two pieces.

2002 4X4 XLT EX - Air Dog
Jason812 is offline  
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Ford Powerstroke Diesel Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in









Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome