ford 1 ton dually does not run right - Ford Powerstroke Diesel Forum
Ford Gassers A Place for Diesel nuts to discuss Ford Gasoline powered vehicles!!!

Powerstroke.org is the premier Diesel Truck Forum on the internet. Registered Users do not see the above ads.
Reply
 
LinkBack Thread Tools Display Modes
  #1  
Old 12-01-2008, 04:33 PM
Powerstroke.org Rookie
 

Join Date: Mar 2008
Location: UP of Michigan
Posts: 14
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
ford 1 ton dually does not run right

hello, i got a 1990 ford 1 ton dually with a 460 efi engine..... The truck starts are runs fine for a little while until it gets warmed up. After a little while running the truck starts to die and wants to stall and runs rough. Also the battery goes low, and the voltage gauge bounces occasionally...... So i am thinking somthing electrical.....i had the altenator tested and they said it was sopposedly good....and i have a brand new battery. what could it be?..... need help!
Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
  #2  
Old 12-01-2008, 04:44 PM
Compression Ignition Addict
 

Join Date: Jan 2008
Location: plantation,fl
Posts: 1,150
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
yea alternator could be dying then batts start to die then there goes your ignition.sounds right.
Reply With Quote Quick reply to this message
  #3  
Old 12-01-2008, 04:57 PM
Sparkplugs Not Required
 

Join Date: Sep 2007
Location: El Paso, Illinois
Posts: 405
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
When it starts to die, is it when you come up to a stop sign or slowing down, i.e. foot on the brake? If the battery and alternator checked ok, then I wouldn't think electrical necessarily.

Could be idle air control or vaccum leak drawing rpm's too low that could cause the battery light to come on........
Reply With Quote Quick reply to this message
  #4  
Old 12-01-2008, 05:50 PM
Thats Mr. Oil Leak.....

 

Join Date: Oct 2006
Location: Cypress / Houston
Posts: 9,526
Thanks: 4
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
Send a message via AIM to MrJohnWayne Send a message via MSN to MrJohnWayne Send a message via Yahoo to MrJohnWayne
Does it still have a single coil and distributor? If so I would get it warm and when it starts to act up test the coil.
Reply With Quote Quick reply to this message
  #5  
Old 12-01-2008, 05:52 PM
Compression Ignition Addict
 

Join Date: May 2007
Location: America
Posts: 6,783
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
.
Reply With Quote Quick reply to this message
  #6  
Old 12-01-2008, 06:49 PM
Powerstroke.org Rookie
 

Join Date: Mar 2008
Location: UP of Michigan
Posts: 14
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
i can barely get it out of my drive way without it acting up, let alone go down the road too far.......the battery light doesnt come on just occasionally the battery tact bounces around. When it acts up its almost like its not getting gas, and runs crappy.......and if i shut it off and start it again the battery seems to get low.....

BTW: where my key goes in to the ignition the steel piece (looks like a wing nut) that fell off of the ignition and steering column.....does that matter.... or cause a electrical error...??
Reply With Quote Quick reply to this message
  #7  
Old 12-01-2008, 06:55 PM
Compression Ignition Addict
 

Join Date: May 2007
Location: America
Posts: 6,783
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
Probably a fuel problem or maybe the inertia switch is going bad.
Reply With Quote Quick reply to this message
  #8  
Old 12-01-2008, 07:01 PM
Member
 

Join Date: Aug 2008
Posts: 71
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
Quote:
Originally Posted by pro11 View Post
i can barely get it out of my drive way without it acting up, let alone go down the road too far.......the battery light doesnt come on just occasionally the battery tact bounces around. When it acts up its almost like its not getting gas, and runs crappy.......and if i shut it off and start it again the battery seems to get low.....

BTW: where my key goes in to the ignition the steel piece (looks like a wing nut) that fell off of the ignition and steering column.....does that matter.... or cause a electrical error...??



Have the module(mounted to the side of the dist.) checked.Could be going bad.



As far as the piece on the key tumbler....be careful...you could break the key off in the tumblers,however it should not cause any other problems.
Reply With Quote Quick reply to this message
  #9  
Old 01-12-2009, 04:38 PM
Member
 

Join Date: Sep 2008
Location: Salamanca, NY
Posts: 66
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
Quote:
Originally Posted by CAT797 View Post
When it starts to die, is it when you come up to a stop sign or slowing down, i.e. foot on the brake? If the battery and alternator checked ok, then I wouldn't think electrical necessarily.

Could be idle air control or vaccum leak drawing rpm's too low that could cause the battery light to come on........
what he said. had the same problem on my 96 f350 with a 351
Reply With Quote Quick reply to this message
  #10  
Old 01-14-2009, 12:47 PM
Compression Ignition Addict
 

Join Date: May 2008
Location: Covington, Ky
Posts: 286
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
If the truck has an EGR valve that COULD be the problem. I had similar drivabilty issues with one but it was a V10 in an f350. Never even made the check engine light come on...
Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Ford Powerstroke Diesel Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
If you do not want to register, fill this field only and the name will be used as user name for your post.
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools
Display Modes

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On



All times are GMT -8. The time now is 10:34 AM.


Powered by vBulletin® Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Search Engine Optimization by vBSEO 3.6.1
Garage Plus, Vendor Tools vBulletin Plugins by Drive Thru Online, Inc.

vB.Sponsors