Cluster & Radio loosing power - Ford Powerstroke Diesel Forum
Ford Gassers A Place for Diesel nuts to discuss Ford Gasoline powered vehicles!!!

User Tag List

LinkBack Thread Tools Display Modes
post #1 of 2 Old 03-04-2013, 11:38 AM Thread Starter Rookie
Mcwlandscaping's Avatar
Join Date: Jun 2012
Posts: 9
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
Cluster & Radio loosing power

In my 05 F350 w/ the 5.4 my gauges and radio keep loosing power at the same time. When the gauges loose power, the CEL remains lit so some things seem to still work but pretty much all the other lights go off with the gauges. I don't believe the gauges are on the delayed power relay as when I pull it only the radio turns off which makes me think it could be a ground that they may share? I have no idea exactly where they would be grounded to. Are the only grounds in the cab the ones on the dash support next to the steering column? I can hear what I believe is the delayed accessory relay powering off when the power (or ground) loss occurs. Can anyone give me some insight on this?

Also, in a probably unrelated case, I'm also getting a P0446 code. Where should I begin checking for causes of this. I know it has to do with the evap emission system vent control circuit but I'm not sure which evap system component is the valve in question.

Thanks guys!

Last edited by Mcwlandscaping; 03-04-2013 at 11:43 AM.
Mcwlandscaping is offline  
Sponsored Links
post #2 of 2 Old 05-12-2013, 03:30 PM Rookie
Join Date: May 2013
Posts: 13
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
Evap I would make sure your gas cap is sealed and such because usually that can set a code.

I'm not so sure about an '05 but I think there may be some grounds behind the kick panels on either side of the truck. Not sure if they will be for the gauges or radio, but they are worth checking out.

Have you ever unplugged anything under the dash or in the engine bay?

96' XLT Bronco. 4.10s, 351W gasser
02' Limited Excursion, stock. V10
96Wronco is offline  
Sponsored Links

Quick Reply

Register Now

In order to be able to post messages on the Ford Powerstroke Diesel Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Please enter a password for your user account. Note that passwords are case-sensitive.


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:


Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.

Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

For the best viewing experience please update your browser to Google Chrome