Cluster & Radio loosing power - Ford Powerstroke Diesel Forum
Ford Gassers A Place for Diesel nuts to discuss Ford Gasoline powered vehicles!!!

Powerstroke.org is the premier Diesel Truck Forum on the internet. Registered Users do not see the above ads.
Reply
 
LinkBack Thread Tools Display Modes
  #1  
Old 03-04-2013, 11:38 AM
Powerstroke.org Rookie
 

Join Date: Jun 2012
Posts: 9
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
Cluster & Radio loosing power

In my 05 F350 w/ the 5.4 my gauges and radio keep loosing power at the same time. When the gauges loose power, the CEL remains lit so some things seem to still work but pretty much all the other lights go off with the gauges. I don't believe the gauges are on the delayed power relay as when I pull it only the radio turns off which makes me think it could be a ground that they may share? I have no idea exactly where they would be grounded to. Are the only grounds in the cab the ones on the dash support next to the steering column? I can hear what I believe is the delayed accessory relay powering off when the power (or ground) loss occurs. Can anyone give me some insight on this?

Also, in a probably unrelated case, I'm also getting a P0446 code. Where should I begin checking for causes of this. I know it has to do with the evap emission system vent control circuit but I'm not sure which evap system component is the valve in question.

Thanks guys!

Last edited by Mcwlandscaping; 03-04-2013 at 11:43 AM.
Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
  #2  
Old 05-12-2013, 03:30 PM
Powerstroke.org Rookie
 

Join Date: May 2013
Posts: 13
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
Evap I would make sure your gas cap is sealed and such because usually that can set a code.

I'm not so sure about an '05 but I think there may be some grounds behind the kick panels on either side of the truck. Not sure if they will be for the gauges or radio, but they are worth checking out.

Have you ever unplugged anything under the dash or in the engine bay?
Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Ford Powerstroke Diesel Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools
Display Modes

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On



All times are GMT -8. The time now is 09:21 AM.


Powered by vBulletin® Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Search Engine Optimization by vBSEO 3.6.1
Garage Plus, Vendor Tools vBulletin Plugins by Drive Thru Online, Inc.

vB.Sponsors