Heater & elec. 4wd Don't Work - Ford Powerstroke Diesel Forum
Ford Gassers A Place for Diesel nuts to discuss Ford Gasoline powered vehicles!!!

User Tag List

LinkBack Thread Tools Display Modes
post #1 of 1 Old 06-22-2011, 09:33 PM Thread Starter
1baddsl's Avatar
Join Date: Aug 2008
Location: Corvallis, OR
Posts: 60
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
Heater & elec. 4wd Don't Work

picked up a 1994 ranger 4x4 to save some fuel. got it cheap for these reasons. It has push 4wd. the lights do not light up and it does not engauge or even try?? And also the blower motor was not working, i put a new one in and still don't work. the new fan works, but no power to wires. The fuses are all good and there is power to the fuse. I am getting frusterated at this thing. Any help would be great. Thank you.

1995 F-250 PSD. Dana 60 front, 6" lift, 35's, Stacks, TW 6 pos., South bend clutch.
1971 SS Elcamino- restored
1baddsl is offline  
Sponsored Links

Quick Reply

Register Now

In order to be able to post messages on the Ford Powerstroke Diesel Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Please enter a password for your user account. Note that passwords are case-sensitive.


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:


Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.

Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

For the best viewing experience please update your browser to Google Chrome