5.4 issue - Ford Powerstroke Diesel Forum
Ford Gassers A Place for Diesel nuts to discuss Ford Gasoline powered vehicles!!!

Powerstroke.org is the premier Diesel Truck Forum on the internet. Registered Users do not see the above ads.
Reply
 
LinkBack Thread Tools Display Modes
  #1  
Old 10-02-2010, 07:50 AM
Compression Ignition Addict
 

Join Date: Dec 2007
Location: Ocala, Fl
Posts: 1,426
Thanks: 0
Thanked 1 Time in 1 Post
Feedback Score: 1 reviews
Send a message via AIM to no-tel-in
5.4 issue

Workin on my Mom's 04 expedition, started missin early this week, hooked AE to it, came up with #4 misfire, so I got the COP and replaced it, drove it, no issue. 2 days later it has developed a hesitation on take off, no codes at all. Looking at it now it appears when I had my big hands back there I cracked the MAX A/C valve because there is now a drip from it. For now I have a 5/8" barbed union in there with 2 hoseclamps.

Any ideas on the hesitation?
Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
  #2  
Old 10-02-2010, 08:02 AM
Compression Ignition Addict
 

Join Date: Sep 2009
Location: Hedgesville, WV
Posts: 1,256
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
I don't remember if the 5.4s suffered from this as much as the 4.0s and 3.0s, but check for moisture in the coil and that the egr valve isn't stuck. Then check the basics: filters, fluids, spark, etc.
Reply With Quote Quick reply to this message
  #3  
Old 10-03-2010, 07:44 PM
Compression Ignition Addict
 

Join Date: Dec 2007
Location: Ocala, Fl
Posts: 1,426
Thanks: 0
Thanked 1 Time in 1 Post
Feedback Score: 1 reviews
Send a message via AIM to no-tel-in
Ok I got her done today. Took it all back apart, replaced 2 more COPs I suspected affected by moisture. so now #2,3,4 have new COPs. Pulled one plug to inspect, and decided to change them all, they looked bad, but were original 120k plugs. Installed 8 new motorcraft plugs. Pulled both fuel rails, all 8 injectors and cleaned them. Checked egr valve, appeared good. Put it all back together and she's as good as new!
Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Ford Powerstroke Diesel Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
If you do not want to register, fill this field only and the name will be used as user name for your post.
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools
Display Modes

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On



All times are GMT -8. The time now is 08:08 AM.


Powered by vBulletin® Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Search Engine Optimization by vBSEO 3.6.1
Garage Plus, Vendor Tools vBulletin Plugins by Drive Thru Online, Inc.

vB.Sponsors