Exploder makes an odd squalling sound and SES light comes on - Ford Powerstroke Diesel Forum
Ford Gassers A Place for Diesel nuts to discuss Ford Gasoline powered vehicles!!!

User Tag List

LinkBack Thread Tools Display Modes
post #1 of 1 Old 07-11-2009, 09:16 PM Thread Starter
Huge Mythical Beast!!
LoxDiesel's Avatar
Join Date: Jan 2009
Location: Almost to the Muck but not quite
Posts: 2,933
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 34 Post(s)
Thanks: 81
Thanked 166 Times in 159 Posts
Feedback Score: 0 reviews
Exploder makes an odd squalling sound and SES light comes on

2000 Exploder 5.0 eddie bauer 2 wheel drive 145k miles
Every once in a while when u romp it youll hear an obnoxious squalling sound under the hood and the check engine light will come on, and the engine will miss here and there a little bit and then clear up but the engine light stays on and u get one code all the time which is P1309 Cam Position Sensor Circuit Fault. So I replaced the cam sensor and saw an idler pulley that had some wear i replaced it also. I still have the same problem. Any help would be good guys thanks !! ^^

Loxahatchee Diesel Custom and Equipment

LoxDiesel is offline  
Sponsored Links

Quick Reply

Register Now

In order to be able to post messages on the Ford Powerstroke Diesel Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Please enter a password for your user account. Note that passwords are case-sensitive.


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:


Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.

Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

For the best viewing experience please update your browser to Google Chrome