01 7.3 sounds like a relay?! - Ford Powerstroke Diesel Forum
Powerstroke.org is the premier Diesel Truck Forum on the internet. Registered Users do not see the above ads.
Reply
 
LinkBack Thread Tools Display Modes
  #1  
Old 05-04-2009, 02:58 PM
Powerstroke.org Rookie
 

Join Date: Jun 2008
Posts: 4
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
01 7.3 sounds like a relay?!


so i went to start the truck and all the gauges go nuts, and it sounds like there's a relay switching on and off. I took the panel off from under the steering wheel and it's coming from a plug that's pretty much in the center of the truck, like under the radio...
wtf?
thanks guys...
Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
  #2  
Old 05-07-2009, 03:20 PM
Powerstroke.org Rookie
 

Join Date: Aug 2008
Posts: 2
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
I had a similar problem. you will get a clicking in that relay because of low voltage.(I forget which relay it is) the batteries tested fine. after the truck was at the dealer for 2 days they found that the alternator was discharging when I was trying to start the truck. its not a very common problem at all! so you might want to try having the alternator tested.

madison
01 f250 175,000 miles
Reply With Quote Quick reply to this message
  #3  
Old 05-07-2009, 03:28 PM
Compression Ignition Addict
 

Join Date: Nov 2007
Location: Arnold, Mo
Posts: 1,567
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
Had what sounds to be the same problem a couple weeks ago and it turned out to be a loose battery connection. I would start by cleaning posts and terminals on the battery and making sure they are tight and then go from there.
Reply With Quote Quick reply to this message
  #4  
Old 05-07-2009, 06:28 PM
Compression Ignition Addict
 

Join Date: May 2008
Location: Bastrop, Tx.
Posts: 443
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
Send a message via Yahoo to Drepka
Happened to me also, was a battery.
Reply With Quote Quick reply to this message
  #5  
Old 05-07-2009, 08:10 PM
Powerstroke.org Rookie
 

Join Date: May 2009
Posts: 11
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
If those all check out good, I have seen on a gas before that there is a fuse in the panel that controls the alternator for charging if it is bad it will seem like the alt is bad just something to check. It will cause the batteries to go dead and the gauges to do funny things.
Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Ford Powerstroke Diesel Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
If you do not want to register, fill this field only and the name will be used as user name for your post.
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools
Display Modes

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On



All times are GMT -8. The time now is 01:50 AM.


Powered by vBulletin® Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Search Engine Optimization by vBSEO 3.6.1
Garage Plus, Vendor Tools vBulletin Plugins by Drive Thru Online, Inc.

vB.Sponsors