Waste gate issue? - Ford Powerstroke Diesel Forum
User Tag List

 
LinkBack Thread Tools Display Modes
post #1 of 6 Old 04-01-2009, 04:57 PM Thread Starter
Powerstroke.org Rookie
 
Join Date: Apr 2009
Posts: 2
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
Waste gate issue?

I have a 03 diesel Ford excursion. It has 77,000 and a dp tuner chip. The turbo is not stock (was told it was a banks big head but dont believe it is). Heres the problem... in the past on occasion when I would start it in the mornings (when it was cold) the turbo would make a high pitched spooling sound. I would pull out and start to climb the hill to work and I had NO power and it was blowing clouds or black smoke (raw fuel). My boost gauge also showed 0. My egt temps would go through the roof (not completely sure if that gauge is accurate). Once it would warm up it would start working properly again.

About a week ago it just stuck that way. No matter how warm it gets or how long I run it, it stays that way. I need it to drive long distances because I am going back to work soon.

I dont know much about these turbos but it sounds like the waste gate is stuck wide open or something. Does anyone have any other opinions. How can it be fixed? Is it something I can do myself with a mechanic buddy of mine? Any advice would be greatly appreciated.
tawny_wade is offline  
post #2 of 6 Old 04-01-2009, 04:59 PM
PMR = JUNK

 
Jake's Avatar
 
Join Date: Nov 2007
Location: NW, Ohio
Posts: 11,199
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 2 reviews
Send a message via AIM to Jake Send a message via Yahoo to Jake
First off what motor is it? 7.3 or a 6.0?

BPS President

2000 F-250, forged rods, 38r turbo, BTS trans, TW tuning and Bad Night Special 50 horse Caterpillar injectors

2002 F-350, remote engine mod



Quote:
Originally Posted by alberta 7.3 View Post
Yeah, I'd probably feel a bit drained after firing twice in rapid succession.
Facebook: Jake Phillips. If you add me tell me who you are.

Jake is offline  
post #3 of 6 Old 04-01-2009, 06:56 PM Thread Starter
Powerstroke.org Rookie
 
Join Date: Apr 2009
Posts: 2
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
7.3

Sorry I didnt include that earlier, I just was under the impression that is the only size they made in 03. But it is the 7.3
tawny_wade is offline  
post #4 of 6 Old 04-01-2009, 07:01 PM
PMR = JUNK

 
Jake's Avatar
 
Join Date: Nov 2007
Location: NW, Ohio
Posts: 11,199
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 2 reviews
Send a message via AIM to Jake Send a message via Yahoo to Jake
Check your IC boots first. Sounds like one popped off and you arent getting any boost.

BPS President

2000 F-250, forged rods, 38r turbo, BTS trans, TW tuning and Bad Night Special 50 horse Caterpillar injectors

2002 F-350, remote engine mod



Quote:
Originally Posted by alberta 7.3 View Post
Yeah, I'd probably feel a bit drained after firing twice in rapid succession.
Facebook: Jake Phillips. If you add me tell me who you are.

Jake is offline  
post #5 of 6 Old 04-08-2009, 05:37 AM
Compression Ignition Addict
 
OUMX117's Avatar
 
Join Date: Sep 2007
Location: Edmond, OK
Posts: 287
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 1 Post(s)
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
Sounds like the EBPV is sticking shut. Check that first and let us know what you find.


2007 F250 Harley 6.0
4.5" lift with 35x12.5-22 Toyo Open Country M/T
SCT X4 with Gearhead SRL, 8k Tow and Unlimited Tow, 4" TB Magnaflow
OUMX117 is offline  
post #6 of 6 Old 04-08-2009, 05:14 PM
PMR = JUNK

 
Jake's Avatar
 
Join Date: Nov 2007
Location: NW, Ohio
Posts: 11,199
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 2 reviews
Send a message via AIM to Jake Send a message via Yahoo to Jake
Quote:
Originally Posted by OUMX117 View Post
Sounds like the EBPV is sticking shut. Check that first and let us know what you find.
I second that.

BPS President

2000 F-250, forged rods, 38r turbo, BTS trans, TW tuning and Bad Night Special 50 horse Caterpillar injectors

2002 F-350, remote engine mod



Quote:
Originally Posted by alberta 7.3 View Post
Yeah, I'd probably feel a bit drained after firing twice in rapid succession.
Facebook: Jake Phillips. If you add me tell me who you are.

Jake is offline  
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Ford Powerstroke Diesel Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in









Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome