Any Thoughts - Ford Powerstroke Diesel Forum
Powerstroke.org is the premier Diesel Truck Forum on the internet. Registered Users do not see the above ads.
Reply
 
LinkBack Thread Tools Display Modes
  #1  
Old 03-19-2009, 12:10 PM
Member
 

Join Date: Jun 2006
Posts: 50
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
Any Thoughts

Hello,
I have a 2001 f-350 7.3 turbo with about 150k miles on the way home the check engine light came on and motor turned sluggish (almost like it was running out of fuel) started sputtering black smoke and egt was 800 to 1000.
I read the code and got P0521. i searched and found the code to be engine oil pressure sensor.
Where to i go from here
Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
  #2  
Old 03-19-2009, 12:17 PM
Compression Ignition Addict
 

Join Date: Jun 2008
Location: Wyoming
Posts: 2,286
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
Check the engine oil level. If its low the injectors wont work like they are supposed to. Hook up a mechanical gauge where the oil pressure sender is and read what actual pressure is.
Reply With Quote Quick reply to this message
  #3  
Old 03-20-2009, 05:49 PM
Member
 

Join Date: Jun 2006
Posts: 50
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
So I topped off oil and let motor completely cool. Starts fine runs fine for about 20 min once it gets to normal operating temp it throws the service engine light and the same code. p0521.
My question is do you think i'm looking at a bad engine oil pressure sensor or could it be my dreaded thought which would be injectors?
Reply With Quote Quick reply to this message
  #4  
Old 03-22-2009, 03:37 PM
Member
 

Join Date: Jun 2006
Posts: 50
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
Just changed all filters air, oil and fuel. Oilchange.
In addition is there a fuel filter behind the air intake? there is a canister type fuel filter I can see. Can anyone tell me if i'm correct on that ?

So now i'm back to my old problem she starts fine and idles fine. When she gets to normal operating she throws the check engine light and same code. sounds like 3 or 4 cylinders shut down. and you have to wait for a complete cool down to get it back to idle..

I pulled the eop sensor and she looks clean as a whistle.
Please powertrokers give me some ideas. i'm on a tight budget and i'm trying to narrow this down.
Thanks in advanced for any help
Reply With Quote Quick reply to this message
  #5  
Old 03-22-2009, 03:40 PM
Compression Ignition Addict
 

Join Date: Jan 2007
Location: Santa Rosa, CA
Posts: 2,026
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
i had the same sypmtoms about a year ago with my 7.3. ended up being the IDM was dying.
Reply With Quote Quick reply to this message
  #6  
Old 03-22-2009, 03:43 PM
Member
 

Join Date: Jun 2006
Posts: 50
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
idm huh did you go with after market of oem replacement
Reply With Quote Quick reply to this message
  #7  
Old 03-22-2009, 03:59 PM
Compression Ignition Addict
 

Join Date: Jan 2007
Location: Santa Rosa, CA
Posts: 2,026
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
Quote:
Originally Posted by jdavey5454 View Post
idm huh did you go with after market of oem replacement
at the time i replaced it, i was unaware of any aftermarket IDM. so, i went with the OEM replacement from Ford. $1100
Reply With Quote Quick reply to this message
  #8  
Old 04-04-2009, 11:59 AM
Member
 

Join Date: Jun 2006
Posts: 50
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
it was a bad wirirng harness that caused the problem. then there was a voltage issure and i changed out the icp. Runs like a raped ape again. Thanks for the advice
Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Ford Powerstroke Diesel Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
If you do not want to register, fill this field only and the name will be used as user name for your post.
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools
Display Modes

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On



All times are GMT -8. The time now is 02:15 PM.


Powered by vBulletin® Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Search Engine Optimization by vBSEO 3.6.1
Garage Plus, Vendor Tools vBulletin Plugins by Drive Thru Online, Inc.

vB.Sponsors