GPR Troubles (96 F250 7.3L) - Ford Powerstroke Diesel Forum

 
LinkBack Thread Tools Display Modes
post #1 of 1 Old 03-14-2009, 06:37 AM Thread Starter
Powerstroke.org Rookie
 
Join Date: Mar 2009
Location: Rock Climbing, WVO, mountaineering, biking, skiing, hiking,
Posts: 15
Thanks: 0
Thanked 0 Times in 0 Posts
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
Feedback Score: 0 reviews
GPR Troubles (96 F250 7.3L)

Hi again
So a couple of days ago I posted a thread explaining the cold start issue with my 96 F250 7.3L turbo diesel and a few people suggested the GPR which I thought was it too, however I just replaced the GPR, I went with the cheaper NAPA one GPR 109, but it is working, I can hear it click on just after the WTS light comes on. but the truck is still not starting. it turns over and dumps white smoke but doesn't start. Any thoughts, ideas, help?
thanks
Geoff
gschellens is offline  
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Ford Powerstroke Diesel Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in









Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome