Building EGT's - Ford Powerstroke Diesel Forum
User Tag List

LinkBack Thread Tools Display Modes
post #1 of 1 Old 02-05-2009, 11:49 AM Thread Starter Rookie
pmonville's Avatar
Join Date: Feb 2006
Location: SAGINAW MI
Posts: 29
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
Exclamation Help Building High EGT's

I have an 01 7.3l that is building high egts without getting into the throttle. When driving @45mph with low rpms the pyro meter starts to climb and climb, Like up to 1000 degs. I here the turbo sound like it does after you start it on a cold morning when it goes to high idle. The only way to cure the problem is to floor it a couple of times. Anyone encounter this before?

Last edited by pmonville; 02-05-2009 at 12:52 PM.
pmonville is offline  
Sponsored Links

Quick Reply

Register Now

In order to be able to post messages on the Ford Powerstroke Diesel Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Please enter a password for your user account. Note that passwords are case-sensitive.


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:


Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.

Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

For the best viewing experience please update your browser to Google Chrome