Bad Pump....maybe - Ford Powerstroke Diesel Forum
User Tag List

 
LinkBack Thread Tools Display Modes
post #1 of 3 Old 01-28-2009, 03:44 AM Thread Starter
Powerstroke.org Rookie
 
Join Date: Jan 2009
Location: Palmdale
Posts: 6
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
Unhappy Bad Pump....maybe

i have an 03 6.0 liter. it runs great overall. it seems like its starving for fuel because it will haul a** at first for about 3 seconds it then sputters like when im running out of fuel. and it won't go any faster. when i let off the throttle and cruise it evens out after a little bit. but when i get on the throttle again it happens. i am thinking its the pump thats under the driver seat on the frame, because before it made a sound like a pump would make. but for a long while before this nuisance it sounds like a full water bottle turned upside down but quit(er). i have changed the two filters about 3k miles ago along with my normal oil change. damn truck is spoiled but won't spoil me. scared many oncoming cars as it happened when i was passing.

:burnout
p.s. looking for sct livewire!!!
fabdf350 is offline  
post #2 of 3 Old 01-28-2009, 04:21 AM
duct tape & zip ties

 
bigcountrysg's Avatar
 
Join Date: Jul 2006
Location: Willis, MI
Posts: 10,761
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
Send a message via Yahoo to bigcountrysg
Check your fuel supply pressure.

It could be the pick up in the tank. It has a fuel screen on it. If that is getting clogged up it will cause this problem as well.


Your Actions Today, Decide Your Future Tomorrow

2005 6.0 Crew Cab Long Box Lariat, current truck

2004 6.0 destroyed by contaminated fuel

2002 7.3L burnt
bigcountrysg is offline  
post #3 of 3 Old 01-28-2009, 04:32 AM Thread Starter
Powerstroke.org Rookie
 
Join Date: Jan 2009
Location: Palmdale
Posts: 6
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
i might also add my truck has 120,000 miles. and sometimes (rarely) the pump makes a normal sound and it runs better. but then it goes back to the way it is.

thanks for your input and advice i will put it into action.
fabdf350 is offline  
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Ford Powerstroke Diesel Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in









Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome