1996 E350 7.3L ROUGH IDLE (? DRIVERS FUEL INJECTOR HARNESS DC) - Ford Powerstroke Diesel Forum
User Tag List

LinkBack Thread Tools Display Modes
post #1 of 1 Old 07-15-2014, 02:04 PM Thread Starter
Powerstroke.org Rookie
Join Date: Apr 2013
Posts: 5
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews


I have a 1996 E350 MEDTEC TYPE III AMBULANCE with Quigley 4x4 conversion. Mileage 140K.

The unit was idling normally 2 days ago and then started to run rough. So far I have replaced fuel filter with no change. I have isolated it to the drivers bank of injectors. All (4) drivers injectors are not working. I know this because I ran the unit and only the passenger side exhaust manifold was warm to touch and drives remained cold.

From my research online I have learned a common problem is the injector wiring harness becomes disconnected. My question is, HOW DO I REMOVE THE DRIVERS SIDE VALVE COVER ON THIS 96 E350? How much do I need to remove? I have the air intake box, dog house and heat shield removed. As you know there is very ltd space and I can't see the top row of valve cover bolts. Any assistance is appreciated. Thank you in advance.


temsinc is offline  
Sponsored Links

Quick Reply

Register Now

In order to be able to post messages on the Ford Powerstroke Diesel Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Please enter a password for your user account. Note that passwords are case-sensitive.


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:


Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.

Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

For the best viewing experience please update your browser to Google Chrome