7.3 died and wonky guages! - Ford Powerstroke Diesel Forum
Powerstroke.org is the premier Diesel Truck Forum on the internet. Registered Users do not see the above ads.
Reply
 
LinkBack Thread Tools Display Modes
  #1  
Old 01-23-2009, 03:43 PM
Powerstroke.org Rookie
 

Join Date: Jan 2009
Posts: 1
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
Exclamation 7.3 died and wonky guages!

My later '99 7.3 starts perfectly, runs perfectly. The other day leaving work, one of the batteries seemed to have drained. It was a bit sluggish but started on the one. I stopped on the way home, and hesitently shut of my truck. when i went to re-start it 10-15mins later, it wouldn't start. I jumped it with another truck, started right up. (lead polarity was correct) Didn't notice anything funny. I let it idle while i moved trucks around and when i went back my guage lights were off. as i drove away all waring lights started to flicker, relays were clicking, but motor ran fine. truck ran fine for .5km turned on the on ramp to the highway and it just died as i applied power. towed home now the guages show random positions, and starter solenoid just clicks and the guages are still acting up. Batteries 10months old same as alt. cps changed 8months ago checked main fuses and they were all good. any ideas?
Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Ford Powerstroke Diesel Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
If you do not want to register, fill this field only and the name will be used as user name for your post.
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools
Display Modes

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On



All times are GMT -8. The time now is 09:30 PM.


Powered by vBulletin® Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Search Engine Optimization by vBSEO 3.6.1
Garage Plus, Vendor Tools vBulletin Plugins by Drive Thru Online, Inc.

vB.Sponsors