Very rapid engine temp increase, strange noise and low boost. - Ford Powerstroke Diesel Forum
Powerstroke.org is the premier Diesel Truck Forum on the internet. Registered Users do not see the above ads.
Reply
 
LinkBack Thread Tools Display Modes
  #1  
Old 01-20-2009, 02:50 PM
Member
 

Join Date: Nov 2008
Posts: 40
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
Very rapid engine temp increase, strange noise and low boost.

Well, I have a big issue here; my truck gelled up last week and the batteries pretty much died, towed it to Ford, they replaced the fuel fliters, and charged up the batteries, and I got my car back. Well, on the ride home I started to notice an intermittent noise while accelerating that sounded like a large fan kicking on, and a bit later, i noticed that while accelerating, while the noise was going, the engine temp started to visibly rise, and when I let off the accelerator, it would drop. Also, when I boosted, the psi would rise like normal, but there was a noticeable lack of power. There was no odd colored smoke coming from the tailpipe, no odd smells at all. My first thought was that the constant resetting when the battery was dead and I was trying to start it might have messed with the ECU, but the rapid increase in engine temps makes me think otherwise. Any help guys? I need my truck for transportation and am kinda SOL without it
Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
  #2  
Old 01-20-2009, 02:59 PM
If it aint a CAT itsa DOG

 

Join Date: Apr 2007
Location: North Branch, MN
Posts: 4,552
Thanks: 0
Thanked 2 Times in 2 Posts
Feedback Score: 0 reviews
what engine?
Reply With Quote Quick reply to this message
  #3  
Old 01-20-2009, 03:00 PM
a truck
 

Join Date: Nov 2007
Location: Lima, OH
Posts: 13,142
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
He has a 6.0
Reply With Quote Quick reply to this message
  #4  
Old 01-20-2009, 03:21 PM
Banned

 

Join Date: Jul 2008
Location: Bryan/College Station/Tyler, TEXAS
Posts: 26,349
Thanks: 6
Thanked 6 Times in 5 Posts
Feedback Score: 1 reviews


has the tstat been changed? or are ya low on coolant?
Reply With Quote Quick reply to this message
  #5  
Old 01-20-2009, 05:15 PM
If it aint a CAT itsa DOG

 

Join Date: Apr 2007
Location: North Branch, MN
Posts: 4,552
Thanks: 0
Thanked 2 Times in 2 Posts
Feedback Score: 0 reviews
Kinda sounds like head gaskets. If it gets warm enough, it will de-rate the engine and not give it full power.
Reply With Quote Quick reply to this message
  #6  
Old 01-20-2009, 05:23 PM
Compression Ignition Addict
 

Join Date: Dec 2007
Location: Flint, MI
Posts: 4,062
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
Could it be an EBPV stuck shut? Do you 6.0 guys have those...? That is what it does on a 7.3 when it gets stuck, low boost, low power, high heat, strange fan-like "SHHHHHH" noise... I wired mine open after that.
Reply With Quote Quick reply to this message
  #7  
Old 01-22-2009, 06:01 PM
Member
 

Join Date: Nov 2008
Posts: 40
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
Found the problem...it was a leak in the EGR cooler
Reply With Quote Quick reply to this message
  #8  
Old 01-22-2009, 06:02 PM
Compression Ignition Addict
 

Join Date: Dec 2007
Location: Flint, MI
Posts: 4,062
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
Good job! Glad it wasn't somethin costly. That's the worst.
Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Ford Powerstroke Diesel Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
If you do not want to register, fill this field only and the name will be used as user name for your post.
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools
Display Modes

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On



All times are GMT -8. The time now is 06:13 AM.


Powered by vBulletin® Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Search Engine Optimization by vBSEO 3.6.1
Garage Plus, Vendor Tools vBulletin Plugins by Drive Thru Online, Inc.

vB.Sponsors