03 6.0L had HPOP Replaced low BOOST now - Ford Powerstroke Diesel Forum
Powerstroke.org is the premier Diesel Truck Forum on the internet. Registered Users do not see the above ads.
Reply
 
LinkBack Thread Tools Display Modes
  #1  
Old 05-20-2014, 09:55 PM
Powerstroke.org Rookie
 

Join Date: May 2014
Posts: 6
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
Exclamation 03 6.0L had HPOP Replaced low BOOST now

hii i know this is my first post but i need some help bad.... I just had my 2nd HPOP installed within 5000 miles now on my 03 6.0L and this time it is only getting up to 7lbs of boost (with bullydog on extreme even) and i can hear it hissing not the typical turbo whine... supposed to be leaving on a trip and cannot figure this out! any ideas?
Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
  #2  
Old 06-23-2014, 12:07 AM
Compression Ignition Addict
 

Join Date: Apr 2013
Posts: 207
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
you either have a bad map,air mass or hole in the intercooler boots.

switch map from another truck if possible if you do not have a scanner and same on air mass.

have a friend you trust brake torque the truck and feel around on the hoses and pipes.

hope this info helps..
Reply With Quote Quick reply to this message
  #3  
Old 06-23-2014, 12:08 AM
Compression Ignition Addict
 

Join Date: Apr 2013
Posts: 207
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
check fuel pressure as fuel dictates boost....sorry it's late.
Reply With Quote Quick reply to this message
  #4  
Old 06-25-2014, 07:45 AM
Powerstroke.org Rookie
 

Join Date: Jun 2014
Posts: 21
Thanks: 0
Thanked 1 Time in 1 Post
Feedback Score: 0 reviews
Check the Y pipe to verify it isn't leaking. That clamp can be tricky to get on. Did they put a new IPR valve on?
Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Ford Powerstroke Diesel Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
If you do not want to register, fill this field only and the name will be used as user name for your post.
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools
Display Modes

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On



All times are GMT -8. The time now is 12:05 PM.


Powered by vBulletin® Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Search Engine Optimization by vBSEO 3.6.1
Garage Plus, Vendor Tools vBulletin Plugins by Drive Thru Online, Inc.

vB.Sponsors