turbo issue? - Ford Powerstroke Diesel Forum
Powerstroke.org is the premier Diesel Truck Forum on the internet. Registered Users do not see the above ads.
Reply
 
LinkBack Thread Tools Display Modes
  #1  
Old 03-11-2014, 06:29 PM
Powerstroke.org Rookie
 

Join Date: Oct 2012
Posts: 8
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
turbo issue?

my 7.3 just pours out black smoke when cold start till it warms up; then it rolls out heavy grey smoke especially at idle cant get over 2lbs of boost even at WOT
Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
  #2  
Old 03-13-2014, 09:24 AM
Powerstroke.org Rookie
 

Join Date: May 2013
Location: Atlantic City
Posts: 14
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
Bad sensor going to the turbo maybe?
Reply With Quote Quick reply to this message
  #3  
Old 03-13-2014, 09:35 AM
Member
 

Join Date: Jul 2013
Posts: 51
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
my truck used to have similar systems and it ended up being the map sensor tube broke off the sensor.. if your facing your truck look about a half foot to the left of the turbo there is a sensor mounted with a tube going into it from the bottom.. make sure there arent leaks in the line or cuts in the wire. if you have a check engine light it could result in a bad map.. low boost is unfortunately a pain in the butt to diagnose, but if its smoke related id start there.
Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Ford Powerstroke Diesel Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools
Display Modes

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On



All times are GMT -8. The time now is 04:22 AM.


Powered by vBulletin® Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Search Engine Optimization by vBSEO 3.6.1
Garage Plus, Vendor Tools vBulletin Plugins by Drive Thru Online, Inc.

vB.Sponsors