New FICM half shell and 10 miles later it shuts down and won't start back up. - Ford Powerstroke Diesel Forum
Powerstroke.org is the premier Diesel Truck Forum on the internet. Registered Users do not see the above ads.
Reply
 
LinkBack Thread Tools Display Modes
  #1  
Old 03-10-2014, 01:30 PM
Powerstroke.org Rookie
 

Join Date: Mar 2014
Location: Arkansas
Posts: 3
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
New FICM half shell and 10 miles later it shuts down and won't start back up.

I have recently done some work to my 2007 6.0/ EGR delete, new oil cooler, new standpipes, new dummy plugs, Sinister coolant filter, and all new oil and fuel filters. Oh I have also replaced the IPR and SCT along with the Hpop cover not the Hpop itself though. Truck ran well after doing all of the work minus the ficm, I replaced the ficm after the truck died (about 2 weeks after I did all the above mentioned work) and I tested the ficm and it was down at around 42v. I got the truck started again after I replaced the ficm half shell and it ran albeit ROUGH about 10 miles than just shut off! I coasted to the side of the highway and had to have it towed back to the house where it sits crank no start condition. I have a scangauge2 and am looking for some advice as to how to go about getting the truck up and running again it has about 200k miles on it but I know she still has some life left in her...
Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Ford Powerstroke Diesel Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools
Display Modes

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On



All times are GMT -8. The time now is 01:44 AM.


Powered by vBulletin® Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Search Engine Optimization by vBSEO 3.6.1
Garage Plus, Vendor Tools vBulletin Plugins by Drive Thru Online, Inc.

vB.Sponsors