7.3 Possible fried PCM? - Ford Powerstroke Diesel Forum
Powerstroke.org is the premier Diesel Truck Forum on the internet. Registered Users do not see the above ads.
Reply
 
LinkBack Thread Tools Display Modes
  #1  
Old 03-01-2014, 06:01 PM
Powerstroke.org Rookie
 

Join Date: Mar 2014
Location: Pittsburgh
Posts: 11
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
Angry 7.3 Possible fried PCM?

I have a 01 f250, 7.3. I just bought the truck 2 weeks ago. It had a Edge Evo in the glovebox, but wasnt connected.

I connected it today, the edge went to the screen after the one that says unlocking PCM. It stayed there for maybe and hour, and did nothing. So I unplugged it and went to start it, Just keeps cranking.

I noticed no WTS light comes on, and check engine stays on. Checked it with a Snap-on scan tool at work and it says "Cant establish connection with PCM." no codes related to not cranking or starting.

I tired unhooking batteries, grounding positive terminal, has fuel, tach does not move when cranking.

Maybe someone can save me about $900 and help me fix it without a new PCM.

Also the PCM I have is a DPC-462. Will a DPC-455 from an 01 E series van work?

Thanks
Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
  #2  
Old 03-02-2014, 07:43 AM
Compression Ignition Addict
 

Join Date: Dec 2007
Posts: 5,178
Thanks: 4
Thanked 115 Times in 109 Posts
Feedback Score: 3 reviews
Coupla things...

First, if the WTS comes on and times-out in 10-15secs, you do Not have a Dead PCM. If the scanner can't communicate either the scanner isn't configured right (see if you can set it to J1850 PWM - we are NOT regular OBD-II) or you could have a bad connection in the connector or To the PCM.

Next, in an '01, some will show cranking rpm on the Tach and some will not. It depends on whether you got the '02 upgrade. So, if you Have a Trans Temp Gauge in the factory Cluster you WON'T see that Tach movement.

I don't know about the EDGE, might have confused things with the computer, you might contact them and give them the Exact steps you took
Reply With Quote Quick reply to this message
  #3  
Old 03-02-2014, 09:13 AM
Powerstroke.org Rookie
 

Join Date: Mar 2014
Location: Pittsburgh
Posts: 11
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
Wts light does not come on at all. Our scanner automatically sets to whatever obd it's plugged into. And the connections are fine for the plug.

It doesn't have a trans temp gauge. I put an aftermarket one in on the pillar
Reply With Quote Quick reply to this message
  #4  
Old 03-02-2014, 09:38 AM
Compression Ignition Addict
 

Join Date: Dec 2007
Posts: 5,178
Thanks: 4
Thanked 115 Times in 109 Posts
Feedback Score: 3 reviews
I see, I misread the WTS and thought you said it Was on...

So, yea, the Tach should rise but, not without the PCM and No WTS = No PCM

BUT, in the Vast majority of cases No PCM = blown Fuse. I'm sure you've looked, I'd look again with a meter, Very carefully (especially #30-19-22, there are several that put power into the PCM).
Reply With Quote Quick reply to this message
  #5  
Old 03-02-2014, 02:48 PM
Powerstroke.org Rookie
 

Join Date: Mar 2014
Location: Pittsburgh
Posts: 11
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
I think it was fuse 19 that was blown, I replaced it and all the other fuses are good. I'll double check though
Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
Reply

Tags
7.3, edge evolution, f250 7.3, pcm

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Ford Powerstroke Diesel Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools
Display Modes

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On



All times are GMT -8. The time now is 04:17 AM.


Powered by vBulletin® Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Search Engine Optimization by vBSEO 3.6.1
Garage Plus, Vendor Tools vBulletin Plugins by Drive Thru Online, Inc.

vB.Sponsors