Injector Problems - Ford Powerstroke Diesel Forum
User Tag List

LinkBack Thread Tools Display Modes
post #1 of 1 Old 10-24-2008, 02:20 PM Thread Starter Rookie
Join Date: Oct 2008
Posts: 4
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
Injector Problems

I think my 95 F250 has bad injectors, not 100% sure though, when i start it it misses on the front 3 injectors of the right bank, but once its warmed up it will run on all 8, i have had the truck hooked up to a computer and manually forced the injectors fire and when i do that it will run on all 8 cold. Replaced o-rings, valve cover gaskets, glow plugs, and checked wiring from glow plug solenoid to plugs as well as connectors from the injectors out all are good

Thanks in advance.

Last edited by Meisner; 10-25-2008 at 11:41 AM.
Meisner is offline  
Sponsored Links

Quick Reply

Register Now

In order to be able to post messages on the Ford Powerstroke Diesel Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Please enter a password for your user account. Note that passwords are case-sensitive.


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:


Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.

Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

For the best viewing experience please update your browser to Google Chrome