7.3 losing power and shaking - Ford Powerstroke Diesel Forum
User Tag List

 
LinkBack Thread Tools Display Modes
post #1 of 2 Old 02-05-2014, 10:59 AM Thread Starter
Powerstroke.org Rookie
 
Join Date: Feb 2014
Posts: 2
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
7.3 losing power and shaking

Need help, this morning I went to pull onto the highway and I had a white plume of smoke come out of my tailpipe and the truck almost immediately had no power, the more I pushed the pedel the more it shook and had no gain in speed. I thought maybe because it was cold and I didn't have it plugged in that could be the problem. On my lunch break though I let it warm up and then took off, ran great until around 65 mph, then it started to shake and lose power again, pulled over and stopped, it took off fine but then wouldn't get over 50 mph and started again. When stopped the truck idles perfectly but with acceleration not so muh, any ideas would be great
Sbramlett3805 is offline  
post #2 of 2 Old 02-10-2014, 03:40 PM Thread Starter
Powerstroke.org Rookie
 
Join Date: Feb 2014
Posts: 2
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
It was the fuel pump fyi
Sbramlett3805 is offline  
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Ford Powerstroke Diesel Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in









Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome