truck in shop for three weeks - Ford Powerstroke Diesel Forum

 
LinkBack Thread Tools Display Modes
post #1 of 3 Old 01-23-2014, 05:07 PM Thread Starter
Powerstroke.org Rookie
 
Join Date: Jan 2014
Posts: 2
Thanks: 0
Thanked 0 Times in 0 Posts
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
Feedback Score: 0 reviews
truck in shop for three weeks

i have an 03 f350 4x4 6.0 and am having an issue nobody seems able to solve so far.
i have owned this truck a little more than a year. i purchased it to replace my 2001 7.3 that was wrecked with over 500k . when i bought it the engine had been replaced with a factory short block buildup. NO EGR, head studs new turbo etc. About two weeks before Christmas i was on the interstate going about 70 . The truck started stuttering and immediately started to cut off. i braked and the revs fell below 1600 and truck was fine . long story short when warm ,truck turns off between 1600-2000 rpm. before its warm no issues in power range at all.
here is what all has been done and to date no solution
new fuel filters, new fuel pump, new (rebuilt) ficm, rebuilt pcm, new ipr sensor,new wiring pigtail.
it has been scanned no codes , oil pump monitored throughout driving range normal until in 1600-2000 range then just cuts off, no issues starting. about out of parts to throw at it , have scoured web looking for similar issue to no avail. Any ideas appreciated.
bufordsooner is offline  
post #2 of 3 Old 01-27-2014, 07:13 AM
Member
 
Join Date: Jan 2014
Location: brownstown Mi
Posts: 86
Thanks: 0
Thanked 12 Times in 12 Posts
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
Feedback Score: 0 reviews
If your IPR duty cycle spikes just before this thing stops running, You could very well have a High Pressure Oil Pump issue. The early design pumps sometimes have an issue where they just cant maintain pressure at high demand. At idle and low demand situations, they will run.
winnersdieseltech is offline  
post #3 of 3 Old 01-28-2014, 02:00 PM Thread Starter
Powerstroke.org Rookie
 
Join Date: Jan 2014
Posts: 2
Thanks: 0
Thanked 0 Times in 0 Posts
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
Feedback Score: 0 reviews
thank you, i had him check that today. I will find out tomorrow but then again he didn't call so i might already have my answer. The great multi year experience i had with my 7.3 is certainly being tested by this 6.0....
bufordsooner is offline  
Reply

Tags
cuts off , mid rpm range

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Ford Powerstroke Diesel Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in









Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome