03 turbo swap now blowing white smoke - Ford Powerstroke Diesel Forum
Powerstroke.org is the premier Diesel Truck Forum on the internet. Registered Users do not see the above ads.
Reply
 
LinkBack Thread Tools Display Modes
  #1  
Old 09-28-2008, 01:38 PM
Compression Ignition Addict
 

Join Date: Jun 2008
Location: South Jersey
Posts: 1,574
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
03 turbo swap now blowing white smoke

I did the 03 turbo swap today and everything went easily. I started up the truck and for some reason it just didnt sound right. Abyway I took to for a drive and nitcued the exhaust was blowing white smoke. I pulled over and switched the tune from race to street mode and that stopped alot of the white smoke. I opened the hood and noticd that the turbo was smoking. I confirmed that the bottom oil feed line was still in to the turbo but it seems it is coming from the turbo itself.

Now I dont know what to do. Should I pull my intake off, change my tunes back to stop and take it back to the dealership. I really dont want to have to pull the turbo back out and put my stock turbo back in. Do you guys think the turbo is bad. I bought it under the presumption that it was rebuilt. I will deal wiht the seller if it is the turbo at a later point. The turbo whistles and built about 15 pounds of boost. I literally went for 3 blocks before I noticed the white smoke and never really got on. It sounds great but I dont know what to do. DO you guys think that it i the oil feed O-ring(were replaced or another part. Is it safe to drive 10 minutes to the dealer. Thanks

Also it did none of this before the turbo swap. I posted this in the 6.0 forum as well. its an emegergenceand didnt know where to post it so i posted in bost forums.
Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
  #2  
Old 09-28-2008, 01:40 PM
Compression Ignition Addict
 

Join Date: Jul 2007
Location: michigan
Posts: 4,243
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
you shouldnt have to take it off to take it to the dealer. as far as boost, that seems low. mine hits 35 and falls to 30 at wot. dont know about the other stuff. im sure someone will chime in.
Reply With Quote Quick reply to this message
  #3  
Old 09-28-2008, 01:45 PM
Compression Ignition Addict
 

Join Date: Jun 2008
Location: South Jersey
Posts: 1,574
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
Quote:
Originally Posted by jamstoyz View Post
you shouldnt have to take it off to take it to the dealer. as far as boost, that seems low. mine hits 35 and falls to 30 at wot. dont know about the other stuff. im sure someone will chime in.
I went maybe max 2400 rpms. No where close to max throttle. I am taking my intake and chip just so the dealer dont give me any problem. I thinking the seals in the turbo are bad. Hopefully they will repace the turbo with an 2003 turbo; that would be awesome. I can dream can't I.\

UPDATE: I jsut smelle dmy exhaust and it don't smell like anything. It is not smoking at idol only when under load. My turbo whistle is loud if that counts for anyhting. ARG
Reply With Quote Quick reply to this message
  #4  
Old 09-28-2008, 01:48 PM
Compression Ignition Addict
 

Join Date: Jul 2007
Location: michigan
Posts: 4,243
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
yes you can dream lol. hows the whistle sound? gotta sound sweet huh?
Reply With Quote Quick reply to this message
  #5  
Old 09-28-2008, 01:50 PM
Compression Ignition Addict
 

Join Date: Jun 2008
Location: South Jersey
Posts: 1,574
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
Quote:
Originally Posted by jamstoyz View Post
yes you can dream lol. hows the whistle sound? gotta sound sweet huh?
Turbo sounds awesome. I could wake up the dead with the whistle. I am goign to see if its low on anitfreese or oil
Reply With Quote Quick reply to this message
  #6  
Old 09-28-2008, 02:07 PM
Compression Ignition Addict
 

Join Date: Apr 2008
Location: Oklahoma City
Posts: 1,671
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
Send a message via AIM to troid123
That sounds very odd, I wonder what would be the reason for the white smoke!?! Sounds like you need to get it to the dealership ASAP. Let us know how it turns out..
Reply With Quote Quick reply to this message
  #7  
Old 09-28-2008, 02:24 PM
Premium Member
 

Join Date: Apr 2007
Location: Round Rock, Tx
Posts: 2,800
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 1 reviews
now u have me all worried about my swap
I did recondition mine, and it looked to be in good shape. just still have the
issue with the bolt stuck on one of the mounting holes. Good luck on getting it figured out, maybe someone more in the know will chime in, so here is a for ya
Reply With Quote Quick reply to this message
  #8  
Old 09-28-2008, 03:06 PM
Compression Ignition Addict
 

Join Date: Jun 2008
Location: South Jersey
Posts: 1,574
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
Quote:
Originally Posted by doubledrop View Post
now u have me all worried about my swap
I did recondition mine, and it looked to be in good shape. just still have the
issue with the bolt stuck on one of the mounting holes. Good luck on getting it figured out, maybe someone more in the know will chime in, so here is a for ya
Mine was supposed to be rebuilt. Now Im screwed. I can take it to the dealer and prolly get my warranty voided. Or I can swap it back out and use my stock turbo. Im not sure if its worth risking my warranty over. Mine was really clean too. it just seems that I have a bad o-ring in my turbo. It just sucks that a 10 dollar parts is causing all of this trouble. I am so pissed. I wanna kill that guy that sold me the turbo
Reply With Quote Quick reply to this message
  #9  
Old 09-28-2008, 03:09 PM
Compression Ignition Addict
 

Join Date: Apr 2008
Location: Oklahoma City
Posts: 1,671
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
Send a message via AIM to troid123
Nobody else have any suggestions as to why he would be blowing white smoke?? Makes me worry about ever attempting this project myself!!
Reply With Quote Quick reply to this message
  #10  
Old 09-28-2008, 03:14 PM
Premium Member
 

Join Date: Apr 2007
Location: Round Rock, Tx
Posts: 2,800
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 1 reviews
Quote:
Originally Posted by jonnysteals View Post
Mine was supposed to be rebuilt. Now Im screwed. I can take it to the dealer and prolly get my warranty voided. Or I can swap it back out and use my stock turbo. Im not sure if its worth risking my warranty over. Mine was really clean too. it just seems that I have a bad o-ring in my turbo. It just sucks that a 10 dollar parts is causing all of this trouble. I am so pissed. I wanna kill that guy that sold me the turbo
did he say why he was selling? I remember that one on ebay, had that brand new 03 pedestal, but he was selling it, one reason I was a bit leary of that one. Mine was a total blind purchase. It was from an unclaimed cargo seller, one pic and no other info, but I was lucky and grabbed it super cheap, so not a major loss if was total trash. My fingers are still corssed on mine though. Hopefully yours is something that can be fixed up pretty easily. Maybe the techies will still chime in here shortly with some info. Good Luck.
Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Ford Powerstroke Diesel Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
If you do not want to register, fill this field only and the name will be used as user name for your post.
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools
Display Modes

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On



All times are GMT -8. The time now is 05:57 AM.


Powered by vBulletin® Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Search Engine Optimization by vBSEO 3.6.1
Garage Plus, Vendor Tools vBulletin Plugins by Drive Thru Online, Inc.

vB.Sponsors