96 psd rough idle hot hard start hot oil pressure drops hot - Ford Powerstroke Diesel Forum
User Tag List

LinkBack Thread Tools Display Modes
post #1 of 1 Old 12-22-2013, 08:33 AM Thread Starter
Powerstroke.org Rookie
Join Date: Dec 2013
Posts: 1
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
96 psd rough idle hot hard start hot oil pressure drops hot

here is the deal I have a 96 f350 7.3l psd i've had it about a year and a half. when i bought it the 5v reference wire was grounded in the cab that powers the baro sensor and throttle pedal sensor. i repaired the wire rebuilt the engine harness replaced the idm and ecm glow plugs batteries cps lpop etc. the truck has run great since. about six months ago on hot days the truck would idle a little rough for a few seconds after it got to operating temp and the oil pressure gage
would shutter but then it would stop. now it will shutter any time it is idling hot and the pressure gage will either flutter or drop completely. once the rpm hit 750 plus it runs fine has power. yesterday i replaced the ipr o-rings and cleaned the screen on the filter housing no change. im thinking injector o-rings but im at a loss. any help is appreciated
motomike is offline  
Sponsored Links

Quick Reply

Register Now

In order to be able to post messages on the Ford Powerstroke Diesel Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Please enter a password for your user account. Note that passwords are case-sensitive.


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:


Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.

Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

For the best viewing experience please update your browser to Google Chrome