02 7.3 blowing fuse - Ford Powerstroke Diesel Forum
Powerstroke.org is the premier Diesel Truck Forum on the internet. Registered Users do not see the above ads.
Reply
 
LinkBack Thread Tools Display Modes
  #1  
Old 12-18-2013, 03:43 PM
Powerstroke.org Rookie
 

Join Date: May 2010
Posts: 28
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 1 reviews
Question 02 7.3 blowing fuse

i have a 02' 7.3 f350 that is blowing fuse # 45. this operates the gauge cluster and the tps (gas pedal) i have done a search of the forums and checked what i could, like chafed wires going to pedal, chafed or rubbed wires going into steering column. there is no rhyme or reason to the fuses blowing. this is a 10 amp fuse, and i have tried using something larger (i know this is a bad idea) but i needed to get home. it makes no difference. i can drive several days without issue and then blow 4 or 5 in a day, (like today). please help, i am at my wits end.
Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
  #2  
Old 01-05-2015, 10:46 PM
Powerstroke.org Rookie
 

Join Date: Dec 2014
Posts: 4
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
I might be able to point you in the right direction

I also have electrical issues with my 2000 350 DRW 7.3 . I just bought this thing that most cable/telephone installers have, its called a tone generator & probe .

1st *****Disconnect all batteries******
2nd wire the tone generator to the terminals in question on the fuse panel
3rd the generator sends amps through the wire(s) then you will have to follow the wire with the probe, this will tell you where a short would be sourced .

the only other thing is that with batteries connected and that circuit closed (operational)
test the amps comming off each of the terminals, if it's higher amperage than 10 then it may be a corroded wire, or faulty source device like a module , or something.

hopefully that helps , let me know what you find

Hunter
Reply With Quote Quick reply to this message
  #3  
Old 01-06-2015, 07:11 AM
Compression Ignition Addict
 

Join Date: Dec 2007
Posts: 5,320
Thanks: 4
Thanked 128 Times in 122 Posts
Feedback Score: 3 reviews
You've look at that wire? Not chafed?

Here's a good link -> https://b7445ba3-a-62cb3a1a-s-sites....attredirects=0
Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Ford Powerstroke Diesel Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools
Display Modes

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On



All times are GMT -8. The time now is 06:25 PM.


Powered by vBulletin® Copyright ©2000 - 2015, Jelsoft Enterprises Ltd.
Search Engine Optimization by vBSEO 3.6.1
Garage Plus, Vendor Tools vBulletin Plugins by Drive Thru Online, Inc.

vB.Sponsors