99' 7.3 Randomly Wont Start - Ford Powerstroke Diesel Forum
 
LinkBack Thread Tools Display Modes
post #1 of 4 Old 09-01-2008, 09:35 AM Thread Starter
Member
 
phahn17's Avatar
 
Join Date: Apr 2007
Location: Nursery, Tx
Posts: 48
Thanks: 0
Thanked 0 Times in 0 Posts
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
Feedback Score: 0 reviews
99' 7.3 Randomly Wont Start

Yest I got in my truck to go somewere and it wouldn't start. No crank, wont turn over, nothing, acting like the batt. has no charge but there fully charged, thought it was the starter because its been acting funny lately, replaced it and no good, im lost?

Paul

99' Ford F350 4x4 PSD Crew Cab Long Box
5in. Turbo Back Straight Pipe w/ 6in. Chrome Tip
Wicked Wheel w/ ATS compressor housing
DIY Tymar Intake
FPR Shim
Dp-Tuner 6 position
Isspro Gauges
ATS 5-Star Tranny Overhaul Kit
Homemade Spring Hanger Drop Level Kit
35in BFG Allterrains
phahn17 is offline  
post #2 of 4 Old 09-03-2008, 06:44 AM
Member
 
BoostedOne's Avatar
 
Join Date: May 2008
Location: Osteen, FL
Posts: 51
Thanks: 0
Thanked 0 Times in 0 Posts
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
Feedback Score: 0 reviews
battery terminals

----------------------------------------------------------------------------------------
Scott- Wondering whats going to break today, and how much it will cost me.
97 F350 Crew Cab Long Bed- E40D swap, divorced 205. 12" suspension lift, no body lift, 42" Swampers

99 Dodge 3500 Cummins dually- stocker

BoostedOne is offline  
post #3 of 4 Old 09-03-2008, 06:49 AM
Compression Ignition Addict
 
szyd's Avatar
 
Join Date: Aug 2008
Posts: 3,540
Thanks: 0
Thanked 0 Times in 0 Posts
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
Feedback Score: 0 reviews
Battery terminals, ground, ignition switch, Check and clean.
szyd is offline  
post #4 of 4 Old 09-04-2008, 05:15 PM
Powerstroke.org Rookie
 
Join Date: Sep 2008
Posts: 6
Thanks: 0
Thanked 0 Times in 0 Posts
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
Feedback Score: 0 reviews
97 7.3 same problem

Sounds like I am having the same problem with my 97 7.3. I am pretty new to working on them so I don't really know where to go with this. I drove the truck to work, 15 minutes later went to start it and nothing. The battery says it still has a charge the lights come on everything seems to work just fine. The truck doesn't crank at all. I just hear a click sound when i turn the ignition. I tried shifting through all the gears and tried starting it again. No crank. No luck
AlaskanJosh is offline  
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Ford Powerstroke Diesel Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in









Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome