CEL on P2285 - Ford Powerstroke Diesel Forum
 
LinkBack Thread Tools Display Modes
post #1 of 8 Old 08-11-2008, 08:17 PM Thread Starter
Member
 
909FF/PM's Avatar
 
Join Date: Apr 2008
Location: Ontario, Ca
Posts: 63
Thanks: 0
Thanked 0 Times in 0 Posts
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
Feedback Score: 0 reviews
CEL on P2285

My truck throw a CEL when I started it this morning and the code was P2285. When I started it was idleing like it had a radical cam in it. I tapped the gas and it idled great and drove great right after. I am leaving for a 500 mile round trip to the river on wednesday morning and i am wondering if I should chance it and drive the truck or have my wife take it to the dealer tomorrow while I am at work. I put on a 4" straight pipe exhaust on two days ago, would that give me a problem at the dealer?

2003 F350 C/C LB FX4 6.0L, 4wd, 8" lift on 37" Xterrains, 4.56 gears, Mag CAI, zoodad mod, high idle mod, Sirius radio, 4" straight pipe to 5" dumping out in front of rear tire

To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.


To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
909FF/PM is offline  
Sponsored Links
Advertisement
 
post #2 of 8 Old 08-11-2008, 08:23 PM
ADMIN AND TECH


 
SCUFFY828's Avatar
 
Join Date: Oct 2006
Location: winston salem north carolina
Posts: 9,316
Thanks: 0
Thanked 11 Times in 11 Posts
Mentioned: 0 Post(s)
Quoted: 1 Post(s)
Feedback Score: 0 reviews
replace icp sensor , thats your problem, some say you need to replace connector also, but its hard to do on a 03 model, so try the sensor , should take care of your problem, if cel does come back on with same code , replace the connector, you may find that sensor is cracked and leaking also


To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.

To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.

ITS STOCK
SCUFFY828 is offline  
post #3 of 8 Old 08-11-2008, 10:28 PM
Banned
 
Join Date: Feb 2008
Location: Northampton,MA
Posts: 792
Thanks: 0
Thanked 0 Times in 0 Posts
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
Feedback Score: 0 reviews
Send a message via AIM to blizzardwarrior7
Icp sensor most likely.....Try unplugging it and see if the problem clears up.
blizzardwarrior7 is offline  
post #4 of 8 Old 08-12-2008, 05:45 AM
Powerstroke.org Fanatic
 
Join Date: Jan 2008
Location: mobile, al
Posts: 119
Thanks: 0
Thanked 0 Times in 0 Posts
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
Feedback Score: 0 reviews
I find them on the 03's cracked and leaking all the time. I would deffinitely check that out.

Ford Power Stroke Tech
If your in Mobile,AL look me up if you have any issues.
Long Live the Diesel!!!
nunly81 is offline  
post #5 of 8 Old 08-12-2008, 05:10 PM
Compression Ignition Addict
 
nylyon's Avatar
 
Join Date: Jun 2008
Location: Brewster, NY
Posts: 1,180
Thanks: 0
Thanked 0 Times in 0 Posts
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
Feedback Score: 0 reviews
Mine just threw the code this past weekend. Going to put in a new sensor first, and if it comes back a new connector too. Not looking forward to doing this....

- Karl
2003 F-250 Crew Cab Short Bed Lariat PSD 6.0 Automatic FX4 Edge Insight with EGT Probe. Coolant Filter. All 6.0's need gauges
Member
To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
nylyon is offline  
post #6 of 8 Old 02-07-2009, 05:34 PM
Powerstroke.org Fanatic
 
2003PSD's Avatar
 
Join Date: Oct 2007
Location: Cleveland
Posts: 113
Thanks: 0
Thanked 0 Times in 0 Posts
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
Feedback Score: 0 reviews
Where is the ICP sensor on 03 6.0L? I have seen pics for the location on 6.0L but mine isn't where the picture has it. I hope im not retarded
2003PSD is offline  
post #7 of 8 Old 02-09-2009, 04:12 PM Thread Starter
Member
 
909FF/PM's Avatar
 
Join Date: Apr 2008
Location: Ontario, Ca
Posts: 63
Thanks: 0
Thanked 0 Times in 0 Posts
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
Feedback Score: 0 reviews
It was hard to find mine also because it was covered by a fabric sleeve. It was on the back of the motor on the driver side below the turbo.

2003 F350 C/C LB FX4 6.0L, 4wd, 8" lift on 37" Xterrains, 4.56 gears, Mag CAI, zoodad mod, high idle mod, Sirius radio, 4" straight pipe to 5" dumping out in front of rear tire

To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.


To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
909FF/PM is offline  
post #8 of 8 Old 02-10-2009, 05:00 AM
Powerstroke.org Fanatic
 
2003PSD's Avatar
 
Join Date: Oct 2007
Location: Cleveland
Posts: 113
Thanks: 0
Thanked 0 Times in 0 Posts
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
Feedback Score: 0 reviews
Quote:
Originally Posted by 909FF/PM View Post
It was hard to find mine also because it was covered by a fabric sleeve. It was on the back of the motor on the driver side below the turbo.
Thanks. We have "summer" weather for once today, so I will try to find it. I was going to try to clean it and if that doesn't work, replace it. Where and how much did you get yours for. Also, is there anyway you have a picture of where it is? By the time I am out of work, its dark.
2003PSD is offline  
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Ford Powerstroke Diesel Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in









Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome