6.0 no boost! help! - Ford Powerstroke Diesel Forum
User Tag List

LinkBack Thread Tools Display Modes
post #1 of 1 Old 11-01-2013, 07:50 AM Thread Starter
Powerstroke.org Rookie
Join Date: Nov 2013
Posts: 1
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
6.0 no boost! help!

i have a 2003 6.0 powerstroke. it has no mods except for 4" exhaust. i was driving down the road yesterday and all of the sudden when i bring the rpms back up, theres no sound of turbo, and no boos ( i have an electronic boost gauge) there are no codes, or anything. last night i undid the EBP sensor, and blew it and the pipe out with compressed air. i also did the same with the MAP tube, sensor, and nipple hat goes into the intake manifold. didnt change a thing. made sure all the boots are tight, everything.! the turbo doesnt cycle on idle, alls you hear is "gargle gargle" engine also runs perfect, except for the lack of a turbo. when i look at my turbo from the intake side, it looks clean as a whistle. the blade spins freely. also when i am in high rpms i can slightly hear the turbo and it makes a whopping 1 pound of boost..thats it! before this happened i could make 25 ibs max! there were no warning signs to this. it was all of a sudden. i am leaning torwards VGT silonoid? somone help!
noahkeebler is offline  
Sponsored Links

turbo 6.0

Quick Reply

Register Now

In order to be able to post messages on the Ford Powerstroke Diesel Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Please enter a password for your user account. Note that passwords are case-sensitive.


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:


Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.

Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

For the best viewing experience please update your browser to Google Chrome