2000 7.3 runs ruff and has no power. - Ford Powerstroke Diesel Forum
Powerstroke.org is the premier Diesel Truck Forum on the internet. Registered Users do not see the above ads.
Reply
 
LinkBack Thread Tools Display Modes
  #1  
Old 07-28-2008, 02:39 PM
Powerstroke.org Rookie
 

Join Date: Sep 2007
Posts: 17
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
2000 7.3 runs ruff and has no power.

My 2000 7.3 was running good then it startered missing and loss power and turned off.Replaced icp and ipr and truck started.It ran good for about an hour then it started missing and loss power.I have also change the air filter and fuel filter and cleaned fuel filter bowl that had dirt and rust but that didnt help and it does not have a check engine light on.I hope somebody can help.
Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
  #2  
Old 07-28-2008, 02:52 PM
Compression Ignition Addict
 

Join Date: Jan 2007
Location: Santa Rosa, CA
Posts: 2,026
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
i had a similar problem a few months ago, ended up being the IDM was bad. get it scanned the next this happens.
Reply With Quote Quick reply to this message
  #3  
Old 07-28-2008, 03:29 PM
Powerstroke.org Rookie
 

Join Date: Sep 2007
Posts: 17
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
I let it run by itself and it stop missing and ran good for about 20 min then it turned off and does not start.I noticed that the oil presure gauge does not move when im cranking it
Reply With Quote Quick reply to this message
  #4  
Old 07-28-2008, 03:33 PM
Compression Ignition Addict
 

Join Date: Oct 2007
Location: Liberty,In
Posts: 767
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
Check the oil level, if its low enough it wont run properly and could be part of the problem. I would definatly have it scaned also.
Reply With Quote Quick reply to this message
  #5  
Old 07-28-2008, 03:43 PM
Powerstroke.org Rookie
 

Join Date: Sep 2007
Posts: 17
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
oil leval is at full line and im going to scan it tomarrow
Reply With Quote Quick reply to this message
  #6  
Old 07-28-2008, 03:44 PM
Compression Ignition Addict
 

Join Date: Mar 2008
Posts: 154
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
have you replaced your cps on it yet?
Reply With Quote Quick reply to this message
  #7  
Old 07-30-2008, 08:39 AM
Powerstroke.org Rookie
 

Join Date: Sep 2007
Posts: 17
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
Well had truck scaned and code po603 internal control module kam error can any body help
Reply With Quote Quick reply to this message
  #8  
Old 07-30-2008, 08:53 AM
ADMIN AND TECH


 

Join Date: Oct 2006
Location: winston salem north carolina
Posts: 9,240
Thanks: 0
Thanked 4 Times in 4 Posts
Feedback Score: 0 reviews
p0603 wont cause your problem, just tells me you might have pulled programmer out or changed programs , have you checked fuel pressure
Reply With Quote Quick reply to this message
  #9  
Old 07-30-2008, 03:04 PM
Powerstroke.org Rookie
 

Join Date: Sep 2007
Posts: 17
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
I charged the batterys up good and i removed the fuel fuel filter lid and alot of air came out.I primeed filter with key on and it turned on and i let it sit for about 30 min and drove it.It didnt turn off but twice it loss power and then it came back no codes im guessing its getting air someware but dont know where.
Reply With Quote Quick reply to this message
  #10  
Old 07-31-2008, 03:31 PM
Jon
Guest
 
Posts: n/a
What?

Quote:
Originally Posted by SCUFFY828 View Post
p0603 wont cause your problem, just tells me you might have pulled programmer out or changed programs?
What? I dont believe that anyone can tell if I have a programmer in my truck. Thats a bunch of hooey!
Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Ford Powerstroke Diesel Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
If you do not want to register, fill this field only and the name will be used as user name for your post.
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools
Display Modes

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On



All times are GMT -8. The time now is 12:31 AM.


Powered by vBulletin® Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Search Engine Optimization by vBSEO 3.6.1
Garage Plus, Vendor Tools vBulletin Plugins by Drive Thru Online, Inc.

vB.Sponsors