Need help, 6.0 running issues - Ford Powerstroke Diesel Forum
User Tag List

LinkBack Thread Tools Display Modes
post #1 of 1 Old 10-21-2013, 12:09 PM Thread Starter Rookie
IamMonsterMan's Avatar
Join Date: Aug 2012
Location: NWCT
Posts: 27
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
Need help, 6.0 running issues

This just happened out of nowhere today and I'm not really sure what the issue is.

I drove about 30 minutes from work to the town I live in, went to 2 different stores and the truck started and ran fine.

I go home to get ready to go to my girlfriends house and I go to start it and it starts and runs at about 250 rpms for about 3 seconds and dies.

I try again and same thing, so I let it cool off for a little while thinking maybe its the HPOP that died

It started sluggishly but eventually the RPM's came up to normal and it started idling normal. I give it some pedal and it revs up normal but then bogs down and goes back to a normal idle.

Then i shut it off and scanned for codes, all I got was for EGR because I have it deleted and I havent been running any tunes for a while because the vanes are stuck in my turbo and i havent gotten around to changing it out yet.

I start it again and look back and notice a pretty good amount of oil smoke is coming out of the stack at idle, so I shut it off.

Start it one more time and now theres no pressure on the dummy gauge in the cluster.

So to me this seems like multiple problems all happening at once, but it does seem like an oil issue somewhere

Any help and knowledge would be appreciated, this is my only means of transportation.

A little info on the truck
-04 6.0
-75000 miles
-EGR delete
-It started to overboost about a month ago so I took the tune off and have been babying it, I have another turbo to put in, time hasnt allowed me to do so yet.

Haven't really had any other issues with the truck since I got it a year or so ago

'04 F-350 6.0 4x4 Reg. Cab Long Bed (SOLD)

Billet Torque Converter || EGR Delete || Airaid Intake || Catless & Mufflerless || 4" Downpipe || 5" Sidepipe w/ 6" Tip || SCT X4 || 35" Hankook Dynapro MT's on 16" Ion's || XDP Coolant Filter || Kenwood Head Unit || 2014 Tailgate
IamMonsterMan is offline  
Sponsored Links

Quick Reply

Register Now

In order to be able to post messages on the Ford Powerstroke Diesel Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Please enter a password for your user account. Note that passwords are case-sensitive.


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:


Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.

Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

For the best viewing experience please update your browser to Google Chrome