'04 6.0L Lost ALL power. - Ford Powerstroke Diesel Forum
 
LinkBack Thread Tools Display Modes
post #1 of 4 Old 09-06-2013, 09:10 PM Thread Starter
Powerstroke.org Rookie
 
Join Date: Sep 2013
Posts: 1
Thanks: 0
Thanked 0 Times in 0 Posts
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
Feedback Score: 0 reviews
'04 6.0L Lost ALL power.

I tried to search some stuff on here but realized soon off that I wouldn't know where to begin....

So I've got some serious stuff going on with my '04 F-250 6.0. First off, up until now, it's pretty much run like a top save for it being a little stuttery/rough sounding now and again after startup. Today, after running around town a bunch with no issues, I get a fire dispatch, load my gear, and start bombing up I-5 to the base. About half way there I notice I'm not doing 75 anymore, I'm doing about 60-65 and NOT able to accelerate, even when floored and when the tranny downshifted into passing gear. Also, there was a shake/stutter coming from the engine. Once I got to the exit, the truck was idling at about 400-500, and very rough. It also took about 50 yards to get going, even with the pedal to the floor. Probably good to note the turbo wasn't spooling up at all either. Once I got to the base the idle was down to about 300 and VERY rough. I shut her down, tried to start her back up, and she coughed and died. No warning lights came on the dash, and the gauges looked good.
Two months ago I had an engine light come on. Code was something to do with an air leak, but went away in a week or so.

The truck has ARP studs, bulletproof ERG cooler, new head gasket, air conditioner, starter, and belt, all done in the last year and a half. I'm up on all oil and fuel filter changes. It's got 242,000-ish miles.

HELP!!!
Boombollie is offline  
Sponsored Links
Advertisement
 
post #2 of 4 Old 01-05-2014, 06:01 PM
Powerstroke.org Rookie
 
Join Date: Jan 2014
Posts: 1
Thanks: 0
Thanked 0 Times in 0 Posts
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
Feedback Score: 0 reviews
I'm dealing with the exact same thing!
Towed a heavy trailer, lost power couldn't gain speed at all, dropped trailer went home. I found a scan gauge ll, drove 15mi to buy it. Started heading home, first red light I hit I barely pulled away from, then just died on me. If you don't have a scan gauge ll, go get one auto zone sells them, you'll have to program it to read individual pids,
Look at your Ficm voltage, and ipr, Ipc readings those will tell you a lot! If you've got under 500psi on the Ipc then it won't start. Mine is hitting 1100-1300 so I'm still trying to get it figured out, thinking hpop, but it's got the pressure to start so? If yours is under 500 you need a hpop or you have a hpo leak internally, if Ficm volts is under 47.5 at any time, koeo, cranking, running suspect the Ficm. Anyway I'm gonna order hpop, all Gaskets, ipr, possibly injector o-rings, dummy plugs, and any other possible leak prone o-rings and have it gone through, I have 240k on mine and I'm sure the more I dig the more problems I'm gonna find. Good luck with yours, I'll let you know if I figure it out.
Renard is offline  
post #3 of 4 Old 01-06-2014, 06:40 AM
Compression Ignition Addict
 
AshevilleEngine.com's Avatar
 
Join Date: Apr 2012
Location: Asheville, NC
Posts: 365
Thanks: 0
Thanked 15 Times in 14 Posts
Mentioned: 0 Post(s)
Quoted: 2 Post(s)
Feedback Score: 0 reviews
You need to get the diagnostic codes to see what's actually going on but my best guess would be an injection issue of some sort. With 242,000 miles it could also be a compression issue.
AshevilleEngine.com is offline  
post #4 of 4 Old 01-13-2014, 12:37 AM
Member
 
Join Date: Jan 2014
Location: Riverside county
Posts: 32
Thanks: 0
Thanked 3 Times in 3 Posts
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
Feedback Score: 0 reviews
SUPERDUTYMIKE is offline  
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Ford Powerstroke Diesel Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in









Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome