Loss of Power ( Turbo Vein Controller?) - Ford Powerstroke Diesel Forum
Powerstroke.org is the premier Diesel Truck Forum on the internet. Registered Users do not see the above ads.
Reply
 
LinkBack Thread Tools Display Modes
  #1  
Old 09-03-2013, 12:47 PM
Powerstroke.org Rookie
 

Join Date: Sep 2013
Posts: 21
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
Loss of Power ( Turbo Vein Controller?)

Hello, My name is Mike and Im new to the forum. I have browsed around often but never needed to post anything.

Vehicle is a 2005 f350

Problem Started all of a sudden.


I am familiar with turbo vehicles but this is my first turbo with the Veins. From my understanding they act as a wastegate.


The problem started after I was out in the country and hit a lot of puddles and got things a bit wet/muddy. The problem started after a large puddle and since it comes and goes. I took off the harness to the controller on the top of the turbo to check for water and there was nothing in it. I sprayed wd-40 while it was off.

With the harness plugged in: turbo boosts as it should but it seems as if its not making it to the motor. At idle it sounds like a jet dryer at a racetrack. While driving it has no power, the turbo spools and builds boost as it should but it seems like it doesnt make any power.

With it plugged in: the idle is quiet like normal. The turbo does not spool much unless you get harder into the throttle. If your hard in the throttle it will eventually spool and build full boost, but it lacks low end power.

I believe this is the problem since the exhaust note is different as well. I'm just not sure if the sensor on top of the turbo is what I should be looking into.

Any help is appreciated as I have to tow my car back from the dyno this week.

Thanks,
Mike
Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
  #2  
Old 09-03-2013, 04:20 PM
Powerstroke.org Rookie
 

Join Date: Sep 2013
Posts: 21
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
Any ideas? Is this a quiet forum?
Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Ford Powerstroke Diesel Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools
Display Modes

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On



All times are GMT -8. The time now is 05:03 AM.


Powered by vBulletin® Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Search Engine Optimization by vBSEO 3.6.1
Garage Plus, Vendor Tools vBulletin Plugins by Drive Thru Online, Inc.

vB.Sponsors