Help!!!???!!! - Ford Powerstroke Diesel Forum
Powerstroke.org is the premier Diesel Truck Forum on the internet. Registered Users do not see the above ads.
Reply
 
LinkBack Thread Tools Display Modes
  #1  
Old 05-26-2008, 02:48 PM
Powerstroke.org Rookie
 

Join Date: May 2008
Posts: 1
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
Help!!!???!!!

02 7.3L w/66K miles. The other day while I was driving the low fuel alarm sounded and the fuel gauge went to empty (3/4 tank of fuel). I stopped and shut the truck off/restarted it and it went back to normal. 1/2 mile down the road it did it again. Restarted it and it has been fine ever since ..... until today. Started the truck fine...while warming up it started to run a little rough, I went to leave the driveway and it ran really rough and blue smoke out exhaust bad. I shut it off and restarted it. It smoked bad and idled really rough. Drained the filter and tried again. It barely wanted to start. Still runs very rough?? Wants to die!!! Any thoughts????? CPS changed already. Fuel filter changed at 50K. Can't drive it.
Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
  #2  
Old 05-26-2008, 04:30 PM
Thats Mr. Oil Leak.....

 

Join Date: Oct 2006
Location: Cypress / Houston
Posts: 9,529
Thanks: 4
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
Send a message via AIM to MrJohnWayne Send a message via MSN to MrJohnWayne Send a message via Yahoo to MrJohnWayne
Probably have a faulty sending unit. Try putting some fuel in it and see if it continues.
Reply With Quote Quick reply to this message
  #3  
Old 05-26-2008, 05:03 PM
RollinEarly05...now


 

Join Date: May 2008
Location: Klamath Falls
Posts: 3,321
Thanks: 27
Thanked 23 Times in 22 Posts
Feedback Score: 10 reviews
You stated fuel filter changed at 50k, I always change my fuel filter with my oil filter. 16k sounds like a lot of miles on one fuel filter...
Reply With Quote Quick reply to this message
  #4  
Old 05-26-2008, 05:48 PM
Powerstroke Techie


 

Join Date: Jun 2007
Location: Huntsville/Arab alabama
Posts: 3,576
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
Wonder if you may have gotten a bad load of fuel?
I change my fuel filter every 8,000 miles or so, 16,000 is double what I would go.
There is also a mixing chamber in the tank that can get stopped up.
A fuel pressure test would rule out and fuel problems.
Here is a look at my filter with about 8,000 on it, sometime during that 8,000 I got at least one bad load of fuel. alabamafrog/Powerstroke Fuel system - Photobucket - Video and Image Hosting
Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Ford Powerstroke Diesel Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools
Display Modes

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On



All times are GMT -8. The time now is 09:15 AM.


Powered by vBulletin® Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Search Engine Optimization by vBSEO 3.6.1
Garage Plus, Vendor Tools vBulletin Plugins by Drive Thru Online, Inc.

vB.Sponsors