05 6.0 bad turbo? - Ford Powerstroke Diesel Forum
Powerstroke.org is the premier Diesel Truck Forum on the internet. Registered Users do not see the above ads.
Reply
 
LinkBack Thread Tools Display Modes
  #1  
Old 08-07-2013, 06:59 AM
Powerstroke.org Rookie
 

Join Date: May 2011
Posts: 4
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
05 6.0 bad turbo?

What's going on guys lets play catch up.

~6 months ago- boost was extremely high with little throttle/ sluggish. Replaced ebp sensor. Fixed problem

1 month ago- showed same symptoms pulled sensor cleaned and installed pigtail for connection on sensor. Seemed to fix

Yesterday- same. Pulled sensor and tube, cleaned/ blew out. Fixed the high boost. But...

Now truck is super sluggish. At WOT truck doesn't "bark" like it use to and take off. Rpms go to about 2300 and turbo will gradually build to about 27 and has a turbo fart at anything above about 15lbs of boost. Makes me think veins are stuck or solenoid went out. Also, Vgt doesn't cycle at idle anymore but have read that stuck veins can also cause this

However, when wot truck doesn't blow black smoke like its waiting for turbo to catch up. Fuel pressure stays between 60-70 doesn't drop down like it use to at wot. Still leaning towards turbo but I would think it would throw smoke, drop fuel press like it use to?

Sct tuner, straight turbo back exhaust, any help would be appreciated.

Soft codes-
p0069-baro press correlation
P0470- ebp sensor malf
P0478- exhaust press control valve malf
Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
  #2  
Old 08-08-2013, 06:04 PM
Powerstroke.org Rookie
 

Join Date: May 2011
Posts: 4
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
Got it, preciate the help!
Reply With Quote Quick reply to this message
  #3  
Old 08-08-2013, 07:14 PM
Member
 

Join Date: Apr 2011
Posts: 49
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
Have you tried pulling EGR valve and cleaning it? I clean my turbo about every 25 thousand miles or so... but thats me..
Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Ford Powerstroke Diesel Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
If you do not want to register, fill this field only and the name will be used as user name for your post.
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools
Display Modes

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On



All times are GMT -8. The time now is 08:23 PM.


Powered by vBulletin® Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Search Engine Optimization by vBSEO 3.6.1
Garage Plus, Vendor Tools vBulletin Plugins by Drive Thru Online, Inc.

vB.Sponsors