loss/lack of power...7.3L IDI turbo - Ford Powerstroke Diesel Forum
User Tag List

LinkBack Thread Tools Display Modes
post #1 of 1 Old 08-01-2013, 06:01 PM Thread Starter
Powerstroke.org Rookie
Join Date: Aug 2013
Posts: 1
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
loss/lack of power...7.3L IDI turbo

Ok so I have searched all over looking for my answer and cant seem to find the right one.

I have a 1994 7.3L IDI Turbo with the E4OD, I just bought it a few days ago and love it so far but I feel it has a big lack of power, also kind of feels like it misfires.

So today i put $20 in my rear tank (Iv run both tanks) and when I left the pump and took a right all of the sudden the truck seemed to come to life like some one turned up a chip. I let off the gas and got on it again and felt great. So i pulled into a parking spot and it was kind of chugging/missng/hard rough idle for a sec and then went back to its gutless self.

it doesnt blow any black smoke, very small ammount of blue when at idle or letting off the gas. has no problems starting cold or hot. It has a a ton of new parts, straight pipe but still has the crappy flat down pipe. what i cant seem to figure out is why I have a lack of power and then today just for a minute it came to life and its back to gutless.

I hope I covered all needed info, any help would be great.

Thanks, Chaz
Grandkrawlers is offline  
Sponsored Links

Quick Reply

Register Now

In order to be able to post messages on the Ford Powerstroke Diesel Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Please enter a password for your user account. Note that passwords are case-sensitive.


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:


Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.

Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

For the best viewing experience please update your browser to Google Chrome